[Samba] Mapped drive behaviour after Windows reboot

Graham Keeling graham at equiinet.com
Fri May 21 08:16:00 MDT 2010


I was previously using samba-3.3.3 on my linux machine.

I could 'map a drive' from a Windows XP machine to access files on the linux

If I rebooted the Windows machine, and tried to access the share again by
clicking on the mapped drive icon, I would be denied, but I would be given a
prompt in which to type in a username and password.

The samba log.clients on the linux machine would say this when I tried to
access the mapped drive:
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD

I've updated to samba-3.4.8. On a reboot now, I am also denied, but I am not
given username/password prompt.
Instead I get a box that says this:

"An error occurred while reconnecting Z: to \\\admin
Microsoft Windows Network : More data is available
The connection has not been restored

The samba log.clients on the linux machine says this for each time I try to
access the mapped drive:
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD

So, it looks like I am getting blocked for the same reason in both cases, but
subsequently, the old behaviour of letting me type a username/password in
made life a lot easier.

Can anybody advise on how to get the old behaviour back with the new samba,
or is this a bug for which I need to file a bug report somewhere?

More information about the samba mailing list