[Samba] RE : RE : RE : Domain not found in Samba 4 AD

Viatte Frédéric Frederic.Viatte at rpn.ch
Mon May 10 09:10:26 MDT 2010

I can not make the command "git" with OpenSUSE. How to do well works?

You had the same error as me? I do not think it tastes because of my version .. but I'll still try!

De : Michael Wood [esiotrot at gmail.com]
Date d'envoi : lundi 10 mai 2010 16:53
À : Viatte Frédéric
Cc : Laurent BARRAILLE; samba at lists.samba.org
Objet : Re: [Samba] RE : RE : Domain not found in Samba 4 AD

2010/5/10 Viatte Frédéric <Frederic.Viatte at rpn.ch>:
> I have version alpha 11. Version 12 is available? I do not find it!

According to http://wiki.samba.org/index.php/Samba4/HOWTO Samba4 alpha
12 was released, but I don't see it here:


and there's not release-4-0-0alpha12 in the GIT repository either.

Anyway, I suggest you just use the latest version from GIT.  I've
tried it out briefly and it seems to work, although it did crash once
for me (a version from just over a week ago.)

See the Samba4 HOWTO page for details on how to check out the source
from GIT and compile it etc.  Note that you will also need "gdb"
installed, or else the build will fail.

> In command line I can not create a user, it makes me an error. (I can describe you tomorrow because I'm not at computer)
> Yes I am logged on as the "administrator" of the server, and I have service pack 2, this can be a problem?
> Yes my firewall is disabled on all computers.

Maybe you can run wireshark on the Windows machine while you are
trying to create the user to see what DNS queries it does and what the
results are, and what other network traffic.  That might explain
what's going wrong.

Does this work for you from the Windows box?  (Using your own
realm/domain, of course):

C:\> nslookup
> set type=srv
> _ldap._tcp.samdom.example.com.

and also _kerberos._udp.samdom.example.com.

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list