[Samba] Fwd: RE: Problems 'make'ing on Solaris 9/10

Gaiseric Vandal gaiseric.vandal at gmail.com
Sat May 8 14:30:29 MDT 2010

Re sh vs bash-

I think you are right.  I don't think any of the make or configure scripts
call a new shell instance.

Re compile-

One of the configure options is 

  --with-wbclient         Use external wbclient (optional)

That would be a standalone executable.
I tried excluding this option from "configure"  and even specifying 


But same error.  I might need to explicitly disable some other options.

-----Original Message-----
From: Michael Wood [mailto:esiotrot at gmail.com] 
Sent: Friday, May 07, 2010 6:04 PM
To: gaiseric.vandal at gmail.com
Cc: Samba
Subject: Re: [Samba] Fwd: RE: Problems 'make'ing on Solaris 9/10

On 7 May 2010 21:57, Gaiseric Vandal <gaiseric.vandal at gmail.com> wrote:
> On Solaris 10 (x86), trying to compile samba 3.5.2
> # mv /usr/ccs/bin/ld /usr/ccs/bin/ld.1
> # ln -s /usr/local/bin/ld   /usr/ccs/bin/ld
> # ./configure --prefix=/usr/local/talloc-2.0.1
> # mv /sbin/sh /sbin/sh.1
> # ln -s /bin/bash /sbin/sh

If I were you I'd try this in a chroot or similar rather than messing
with the system.

> So no more issues related to libtalloc BUT the compile still failed:
> creating /export/src/Samba/samba-3.5.2/source3/exports/libwbclient.syms
> Linking shared library bin/libwbclient.so.0
> /usr/local/lib/gcc/i386-pc-solaris2.10/3.4.6/crt1.o: In function `_start':
> crt1.s:(.text+0x5c): undefined reference to `main'
> collect2: ld returned 1 exit status
> make: *** [bin/libwbclient.so.0] Error 1
> -sh-3.00#

Strange.  That looks as if ld is trying to generate a program that
should have a main() function instead of a shared library.  Or
something like that.

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list