[Samba] urgent

Volker Lendecke Volker.Lendecke at SerNet.DE
Mon Mar 29 05:36:15 MDT 2010

On Mon, Mar 29, 2010 at 11:30:00AM +0000, Johnny R wrote:
> reetings List,
> I am a newbie in this list so please be indulgent.
> I am actually about running a samba (PDC) with OpenLDAP in Debian. I
> installed it (Samba) and configured it, but it didn't still work. Here are
> some outputs:
> from *net getlocalsid*
> csiidebian:~# net getlocalsid
> [2010/03/29 17:57:33,  0] lib/smbldap.c:1086(smbldap_connect_system)
>   failed to bind to server ldap:// with
> dn="cn=admin,dc=csimaroc,dc=net" Error: Invalid credentials
>         (unknown)
> SID for domain CSIDEBIAN is: S-1-5-21-2033656986-2476707763-2123375676
> csidebian:~#
> it still give me the wrong SID.
> When I tried to add or search some entry in the  Ldap DB, it gave me the
> following error: "
> ldap_sasl_interactive_bind_s: Invalid credentials (49)", I d like to notify
> that I have the same password for samba admin and ldap admin (smbpasswd and
> slappasswd). I was been in this error since 2 weeks   so please help me, it
> makes me crazy!

This might be solved by calling "smbpasswd -W" and typing in
the correct password for cn=admin,dc=csimaroc,dc=net.


More information about the samba mailing list