[Samba] failed to execute child process

Larry and Sandi Miller millerlns at centurytel.net
Thu Mar 11 20:24:39 MST 2010

Will try. Is samba3sam.so part of a samba4 package? That may explain some of
my problem.

-----Original Message-----
From: Dale Schroeder [mailto:dale at BriannasSaladDressing.com] 
Sent: Thursday, March 11, 2010 1:36 PM
To: Larry and Sandi Miller; Samba
Subject: Re: [Samba] failed to execute child process

Sounds more like a corrupted dpkg than a Samba issue.
I think you will need to determine what's broken there before you can 
fix the Samba install.


On 03/11/2010 12:06 AM, Larry and Sandi Miller wrote:
> Long story short - very newbie on Linux. Loaded successfully Ubuntu9.10.
> Intrigued by Samba, tried to load newest version. Screwed up something, so
> tried to uninstall then re-install.
> Now getting "Could not launch samba" with message 'Failed to execute child
> process "/usr/lib/samba/ldb/samba3sam.so" (no such file or directory).
> Version is 2:3.4.0-3ubuntu5.4
> Noted directory does not exist on my machine.
> Tried aptitude reinstall samba. Message back 'samba is not currently
> installed so it will not be reinstalled.'
> Tried aptitude install samba. This appeared to work, but no joy when I
> to launch it. Still got the message "the program 'samba' is currently not
> installed. You can install it by typing: sudo apt-get install samba4."
> I do have a samb4 package in archive, however do not understand why
> samba3.xx appears to be installed, but isn't and I get the other noted
> messages. I want to install samba3.xx
> Thanks,
> Larry

More information about the samba mailing list