[Samba] failed to execute child process

Larry and Sandi Miller millerlns at centurytel.net
Wed Mar 10 23:06:23 MST 2010

Long story short - very newbie on Linux. Loaded successfully Ubuntu9.10.
Intrigued by Samba, tried to load newest version. Screwed up something, so
tried to uninstall then re-install.

Now getting "Could not launch samba" with message 'Failed to execute child
process "/usr/lib/samba/ldb/samba3sam.so" (no such file or directory).

Version is 2:3.4.0-3ubuntu5.4


Noted directory does not exist on my machine.

Tried aptitude reinstall samba. Message back 'samba is not currently
installed so it will not be reinstalled.'

Tried aptitude install samba. This appeared to work, but no joy when I tried
to launch it. Still got the message "the program 'samba' is currently not
installed. You can install it by typing: sudo apt-get install samba4."

I do have a samb4 package in archive, however do not understand why
samba3.xx appears to be installed, but isn't and I get the other noted
messages. I want to install samba3.xx



More information about the samba mailing list