[Samba] Joining an AD domain when hostname != netbios name

Jonathan Barber jonathan.barber at gmail.com
Thu Jun 17 11:22:45 MDT 2010

On 17 June 2010 16:59, Robert Freeman-Day <presgas at gmail.com> wrote:
> Hash: SHA1
> On 06/17/2010 11:08 AM, Jonathan Barber wrote:
>> I'm trying to join a RHEL5 host to an AD domain, and can do this
>> successfully when I set those hostname to the same value as the samba
>> "netbios name" parameter. However, when I try with a hostname !=
>> netbios name, it fails. Is it possible to join a machine when the
>> hostname isn't the same as the netbios name?
>> The reason for wanting this is because I have a whole load of servers
>> with hostnames > 15 characters in length and changing the hostname
>> isn't realistic.


>> So; am I doing something wrong, or is it not possible?
>> Many thanks.
>> --
>> Jonathan Barber <jonathan.barber at gmail.com>
> One thing to note is that a machine can have more than one hostname as
> well as more than one DNS record.
> I was able to get someone joined by putting everything in the /etc/hosts
> file:
> localhost.localdomain localhost
> yet-another-joining-test.ptin.corppt.com
> yet-another-joining-test yetanothertest1.ptin.corppt.com yetanothertest1
> #note the above is all one line starting from
> The smb.conf setup you have should not need to be modified.
> You will likely want to either reset or completely delete the
> yetanothertest1 machine account in ADUC, as one of your messages says
> the value exists.
> Tell us if that works for you!

Unfortunately it doesn't. However, I do get a slightly different error message:
Failed to set servicePrincipalNames. Please ensure that
the DNS domain of this server matches the AD domain,
Or rejoin with using Domain Admin credentials.
Failed to disable machine account for 'YETANOTHERTEST4' in realm
Failed to disable machine account in AD.  Please do so manually.
Failed to join domain: Constraint violation

I've also tried Christoph's suggestion of adding the hostname (first
just the hostname, then the hostname and the FQDN) to the "netbios
aliases" parameter, but that gave the same error as above.

I don't have access rights to delete entries in AD, so I'm upto
yetanothertest6 now :)

I'll try samba-latest tomorrow to see if it's a problem with the RHEL package.

Thanks for your suggestions, knowing it should be possible is half the battle.


> ________
> Robert Freeman-Day
> https://launchpad.net/~presgas
> GPG Public Key:
> http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0xBA9DF9ED3E4C7D36
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> iEYEARECAAYFAkwaRl4ACgkQup357T5MfTY7nACg0r5wXXu/1QBHH6rlBhF8IwKV
> tegAoJI71CfWDmLPkKMmD8C4nhx2eiL/
> =1gKS

Jonathan Barber <jonathan.barber at gmail.com>

More information about the samba mailing list