[Samba] Winbind not starting in AD member(samba joining domain) configuration.

justin joseph justin at elinanetworks.com
Mon Jun 14 04:38:47 MDT 2010


Facing an issue with winbind not starting with below error log(taken 
from /var/log/syslog):

Jun 14 15:48:33 enpaq winbindd[15941]: [2010/06/14 15:48:33,  0] 
Jun 14 15:48:33 enpaq winbindd[15941]:   WARNING: No path in service 
printers - making it unavailable!
Jun 14 15:48:33 enpaq winbindd[15942]: [2010/06/14 15:48:33,  0] 
Jun 14 15:48:33 enpaq winbindd[15942]:   initialize_winbindd_cache: 
clearing cache and re-creating with version number 1
Jun 14 15:48:33 enpaq winbindd[15942]: [2010/06/14 15:48:33,  0] 
Jun 14 15:48:33 enpaq winbindd[15942]:   Could not fetch our SID - did 
we join?
Jun 14 15:48:33 enpaq winbindd[15942]: [2010/06/14 15:48:33,  0] 
Jun 14 15:48:33 enpaq winbindd[15942]:   unable to initialize domain list

the version installed is Version 3.4.7(lucid packages), the 
configuration files (given below) were working
as is on Ubundy hardy, the winbind issue started only when I migrated to 

knit works and smbd and nmbd processes starts up as well:

root at enpaqadserver.com:/etc/samba# kinit Administrator at ENPAQADSERVER.COM
Password for Administrator at ENPAQADSERVER.COM:
root at enpaqadserver.com:/etc/samba# klist -e
Ticket cache: FILE:/tmp/krb5cc_0
Default principal: Administrator at ENPAQADSERVER.COM

Valid starting     Expires            Service principal
06/14/10 16:01:11  06/15/10 01:59:00  
        renew until 06/15/10 16:01:11, Etype (skey, tkt): ArcFour with 
HMAC/md5, ArcFour with HMAC/md5
root at enpaqadserver.com:/etc/samba#

Configurations files below:

root at enpaqadserver.com:/etc/samba# cat /etc/krb5.conf
        default_realm = ENPAQADSERVER.COM
        dns_lookup_realm = true
        dns_lookup_kdc = true
        ticket_lifetime = 24h
                kdc = winserver.enpaqadserver.com:88
                admin_server = winserver.enpaqadserver.com:749
                default_domain = enpaqadserver.com

        .enpaqadserver.com = ENPAQADSERVER.COM
        enpaqadserver.com = ENPAQADSERVER.COM

root at enpaqadserver.com:/etc/samba# cat smb.conf
# Global parameters                           
  workgroup = ENPAQADSERVER                   
  realm = ENPAQADSERVER.COM                   
  password server = ENPAQADSERVER.COM
  preferred master = no
  domain master = false
  local master = no
  server string = Samba file and print server
  security = ADS
  encrypt passwords = true
  log level = 3
  log file = /var/log/samba/%m
  max log size = 50
  winbind separator = /
  winbind enum users = yes
  winbind enum groups = yes
  winbind use default domain = yes
  printcap name = cups
  printing = cups
  idmap uid = 10000-20000
  idmap gid = 10000-20000
  comment = Home Directories
  path    = /opt/samba/data/share
  valid users = %S
  read only = No
  browseable = No

  comment = All Printers
  browseable = no
  printable = yes
  guest ok = yes

The same adserver and these same configuration files, including the same 
DNS settings on
the samba machine works fine when I were using Ubuntu hardy 
distribution.  I tried googling
for this issue and tried on my own but could not resolve this.

Thanks in advance

More information about the samba mailing list