[Samba] Files missing (not hidden)

Gaiseric Vandal gaiseric.vandal at gmail.com
Tue Jul 27 14:40:15 MDT 2010

I have run into this with various Office documents.

When you save an Excel file it will delete the file and rewrite a brand 
new file with the same name.    If you don't have sufficient permisisons 
to write the file AND set various attibrutes  the save process will 
fail.    You will probably see this with MS PowerPoint as well-  
although it only does the delete/fullwrite on every 5th save or so.

MS Office applications like to change the permissions of a file when 
saving/creating files.  So even if you can create a file in the 
directory you may still have this problem.

You probably do not have this problem with notepad.

I am running Samba on Solaris 10, with ZFS, which supports a variety of 
ACL's.    In addition to requiring read/write privledges on the 
directory, users also need permissions to write attributes.

You may need to use the "getfacl" command to compare permissions on 
documents before and after saving them.  (or seeing the permissions in 
the Windows file explorer.)   You may need to experiment with setting 
the permissions on the parent directory.    Or with your acl parameters 
in smb.conf

On 07/27/2010 04:19 PM, Dustin Krysak wrote:
> Hi there,
> I have a samba install on centos 5 with the latest version of samba (samba-3.0.33-3.28). There were two files that just disappeared. The users description is as below:
> I had worked on them – both were excel files that linked to each other. I saved it as a different name than the original I worked from (which I found to be very “buggy”) – the originals are still in their respective folders and can be opened. The next morning we opened the documents on Denby’s computer and first it wouldn’t let her save it – not even “save a copy”, I got messages the day before it disappeared saying it was locked for editing – but I was the only one who had used it and it was closed. I had to close excel and re-open then it worked.
> After Denby tried to edit the docs from her computer I came back to my computer to complete the work and it was no longer in the folder and when I tried to open it from excel I get the message (as per attached). I tried to do a simple search for it and it told me the shortcut has been changed or moved so it no longer works properly.
> In my conf, the files resided on the "laverde" share.
> # cat /etc/samba/smb.conf
> [global]
> workgroup = CONAME
> netbios name = coname
> server string = (%L)
> wins support = Yes
> name resolve order = wins bcast hosts
> passdb backend = tdbsam
> username map = /etc/samba/smbusers
> add user script = /usr/sbin/useradd -m %u
> delete user script = /usr/sbin/userdel -r %u
> add group script = /usr/sbin/groupadd %g
> delete group script = /usr/sbin/groupdel %g
> add user to group script = /usr/sbin/groupmod -A %u %g
> delete user from group script = /usr/sbin/groupmod -R %u %g
> add machine script = /usr/sbin/useradd -s /bin/false -d /var/lib/nobody %u
> # Note: The following specifies the default logon script.
> # Per user logon scripts can be specified in the user account using pdbedit
> logon script = %U.bat
> # This sets the default profile path. Set per user paths with pdbedit
> logon path =
> logon drive = H:
> logon home = \\%L\%U
> domain logons = Yes
> os level = 35
> preferred master = Yes
> domain master = Yes
> idmap uid = 15000-20000
> idmap gid = 15000-20000
> #mac hacks
> follow symlinks = yes
> unix extensions = no
> #veto files = /.DS_Store/._.*/DesktopFolderDB/Network Trash Folder/resource.frk/TheFindByContentFolder/TheVolumeSettingsFolder/
> delete veto files = true
> hide dot files = yes
> [homes]
> comment = Home Directories
> valid users = %S
> read only = No
> browseable = No
> [netlogon]
> comment = Network Logon Service
> path = /shares/netlogon
> admin users = root
> guest ok = Yes
> browseable = No
> [main]
> comment = Share for the users in the main group
> path = /shares/main
> users = @main
> force group = main
> create mask = 0660
> directory mask = 0771
> writeable = yes
> [laverde]
> comment = Share for the users in the leverde group
> path = /shares/laverde
> users = @leverde
> force group = leverde
> create mask = 0660
> directory mask = 0771
> writeable = yes
> Any ideas?
> These files never made it into our backups as this happened prior to the actual backup.
> Thank you.
> D

More information about the samba mailing list