[Samba] Samba 3.4 Panic in Debian

Dale Schroeder dale at BriannasSaladDressing.com
Mon Jan 25 10:14:31 MST 2010

On 01/18/2010 9:16 AM, Christian Perrier wrote:
> Dale Schroeder a écrit :
>> I've suspected that ever since reading Karolin's release notes for
>> 3.4.4.  Debian has not yet released 3.4.4
>> to "testing", but I'll gladly try it as soon as it's available.  For the
> That should happen in about one week, assuming that no dependency chain
> is blocking it.
> (roughly speaking, "releasing to testing" is automated and happens after
> 10 days in unstable, if no RC bug appeared *and* if the dependecies can
> be satisfied in testing)
>> interim, all winbind systems are reverted
>> back to "stable" (3.2.5-4lenny7).  The ldap and standalone systems run
>> perfectly well under 3.4.3.
> I think you can anyway safely (but manually) install 3.4.4 packages on
> testing systems with dpkg (better try it with "--dry-run" before).
Things got worse today, as winbind on stable (3.2.5) now ceases to 
work.  It appears the join is no longer valid, and a testjoin yields 
errors concerning encryption (as does net ads join):
     0] libads/sasl.c:ads_sasl_spnego_bind(819)
     kinit succeeded but ads_sasl_spnego_krb5_bind failed: Program lacks 
support for encryption type

Upgrade to unstable (3.4.5) yields the same error message.  To cover all 
the bases, I also tried testing 3.4.3, and it also has the same error, 
although the order of the 1st line is slightly different:
     0] libads/sasl.c:819 (ads_sasl_spegno_bind)

This time, it seems to be an ADS specific winbind error.

I have attempted with the current kernel - 2.6.32-trunk-686 and the 
previous kernel - 2.6.30-2-686.

What kind of encryption change has occurred, and which program is it 
referring to as lacking the encryption type - samba or krb5?

More information about the samba mailing list