[Samba] strange issue with xerox printer: unable to configure driver

Guillaume Rousse Guillaume.Rousse at inria.fr
Wed Jan 6 08:05:32 MST 2010

Le 23/12/2009 18:23, Ryan Suarez a écrit :
> Hi,
> Still working this out with the vendor.
> Could you guys try this driver with the Xerox 7xxx model and let me know
> if it plays nicer with samba?
> http://www.support.xerox.com/go/getfile.asp?Xlang=fr_FR&XCntry=FRA&objid=55425&EULA=1&prodID=WC7228_WC7235_WC7245&Family=WorkCentre&ripId=&langs=English%20(US)&plats=Windows%20XP&Xtype=download&uType=
> Their thoughts is the device mode issue which we're all familiar with:
> "Be aware that a valid device mode can only be initiated by a _printer
> admin_
> <http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/smb.conf.5.html>
> or root (the reason should be obvious). Device modes can be correctly
> set only by executing the printer driver program itself. Since Samba
> cannot execute this Win32 platform driver code, it sets this field
> initially to NULL (which is not a valid setting for clients to use).
> Fortunately, most drivers automatically generate the printer driver data
> that is needed when they are uploaded to the/ [print$]/ share with the
> help of the APW or rpcclient. "
I just tried.

I can assign any driver, and correctly set default printing properties 
(which I can't with current driver). However, I can't print. I guess 
this is because my specific printer model (7435)  is not supported by 
this old driver version: it's not listed, and I tried all included 
models without success.

So far, I've got the choice between a printing-but-not-configurable 
driver, and a non-printing-but-configurable one :)
Guillaume Rousse
Service des Moyens Informatiques
INRIA Saclay - Île-de-France
Parc Orsay Université, 4 rue J. Monod
91893 Orsay Cedex France
Tel: 01 69 35 69 62

More information about the samba mailing list