[Samba] Failed to issue the StartTLS instruction: Decoding error

Gary Wardell gwardell at gwsystemsdns.net
Mon Feb 22 09:10:20 MST 2010


I'm a new user.  I'm trying to get Samba setup as an member server in an Active Directory Domain and operating as a File Server
with SSO.

I've been getting lots of these errors in the messages file.  I also get a similar message in bash with ldapsearch -ZZ

Feb 20 00:19:32 linux-hh3x net: [2010/02/20 00:19:32, 0] lib/smbldap.c:smb_ldap_start_tls(596)
Feb 20 00:19:32 linux-hh3x net: Failed to issue the StartTLS instruction: Decoding error

My configuration is:

OpenSUSE 11.1
Samba 3.2.7

Windows Server 2000 sp4

The Linux box shows up in the Active Director Computers and in the Windows Server Manager.

And in Network Places shows the Samba Shares; however I'm not able to access any of the Samba Shares.  When I click on one it
hangs for several seconds like it's timing out, and then asks me for credentials.  I enter some and it then denies access.  I have
tried both my Windows domain administrator logon and the Linux root logon.  Both don't work.  And obviously SSO doesn't work.

The AD domain is working correctly with windows clients so I'm assuming the problem is on the Linux end.

Since this is a new setup I'm assuming that it is a configuration issue.

I have tried several options with no noticeable difference.

My Goggle searches reveal that many people have had this problem in the past (circa 2002-2004) but I didn't see any solutions
posted.  The threads usually just show the initial post and then go cold.

Any help trouble shooting this will be greatly appreciated.


More information about the samba mailing list