[Samba] Problems accessing a file share using kerberos

Jeremy Allison jra at samba.org
Fri Feb 19 22:44:12 MST 2010

On Fri, Feb 19, 2010 at 07:08:48PM -0800, Pedro Côrte-Real wrote:
> Hi,
> I'm trying to access a file share on what I believe is a netapp server
> using kerberos authentication. I've done a kinit and gotten
> credentials and then ran:
> $ smbclient -U pedrocr //gsb-filer2/pedrocr -k -d10
> This actually increased the number of credentials klist shows so looks
> good in that regard. Howeever, I got the error:
> """
> lang_tdb_init: /usr/share/samba/en_US.UTF-8.msg: No such file or directory
> did you forget to run kinit?
> """
> Searching around I found this relating to this error on NetApp:
> http://lists.samba.org/archive/smb-clients/2008-September/000785.html
> Seems like it doesn't like the workgroup name, even though here I'm
> not using one. I've tried 20 different combinations of how to do it,
> with and without the workgroup name (which should be "win") and it
> still wouldn't work.
> I also tried using this without kerberos like so:
> $ smbclient -U win/pedrocr%mypassword //gsb-filer2/pedrocr
> this actually returns NT_STATUS_WRONG_PASSWORD although the password
> is indeed correct.
> I'm running Ubuntu 9.10 with smbclient version 3.4.0-3ubuntu5.4. Do I
> need to actually install samba itself and connect it to the domain for
> this to work? I'm doing all this on the Stanford campus network in
> case anyone knows anything about that install in particular.

Should work. What version of the NetApp OS release is this ?

Can you get a debug level 10 trace from smbclient so we might
be able to track this down ?

I'm local to you, but will be at Connectathon all next week
(might get to test with some NetApp folks), but after that
could come take a look on campus.


More information about the samba mailing list