[Samba] net rpc join failed ?

Annada Prasana Prusty annadaprasana at gmail.com
Wed Feb 10 22:13:32 MST 2010


i have further investigated. i got this error message "get_trust_pw_clear:
could not fetch clear text trust account password for domain <my_domain>".
It is looking for machine password inside secrets.tdb with key =
SECRETS/MACHINE_PASSWORD/MY_DOMAIN, but there is no record at the same
offset. But tdbdump shows the record inside tdb file, even in hexdump also
shows the record in different offset. So i am not able to trace it, where is
the problem.
I have tried with old samba versions also, but the same result. Please help.



On Fri, Feb 5, 2010 at 7:48 PM, Annada Prasana Prusty <
annadaprasana at gmail.com> wrote:

> Hi,
> I am using samba-3.4.5.
> I am trying for join to domain controller, with security=domain in
> smb.conf.
> But it fails with following debug messages.
> *
> rpccli_netlogon_set_trust_password: unable to setup creds
> rpc command function failed ! (NT_STATUS_ACCESS_DENIED)
> ......
> get_schannel_session_key: could not fetch trust account password for domain
> net_rpc_join_ok: failed to get schannel session key for server MYSERVER for
> unable to join domain MYDOMAIN
> return code = -1.*
> Can you please help , where is the problem.
> Thanks
> Annada

More information about the samba mailing list