[Samba] Domain login delays w2k8 R2

Martin Hochreiter linuxbox at wavenet.at
Wed Feb 3 07:52:38 MST 2010

Am 2010-02-03 15:19, schrieb Åke Holmlund:
> Hello!
> From what I can see, there is no DNS-traffic around the time of the
> gaps and the DNS-activity I can see in onther places seems ok. There
> is almost no network traffic and no CPU activity during the gaps so
> it looks like some kind of timeout issue.
> It may be of interest that, for the moment, IPv6 is beeing used.
> Sometimes we also have quite a long delay if we click on the "View
> computers and devices" link in the "Network and Sharing Center".
> Regards,
> Åke Holmlund
> --On 2 februari 2010 10.16.22 -0800 Jeremy Allison <jra at samba.org> wrote:
>> On Tue, Feb 02, 2010 at 07:03:11PM +0100, Åke Holmlund wrote:
>>> Hello!
>>> We have a w2k8 R2 64-bit machine in a Samba 3.4.4 controlled domain.
>>> When logging in as a domain user there is a ~30 sec delay waiting
>>> for the User Profile Service. This has nothing to do with the size
>>> of the user profile. Looking at the network traffic I can see 2
>>> gaps, the first about 11 sek and the second about 19 sek with
>>> no packets sent except one TCP ACK (from the client) in each gap.
>>> Between the gaps there is only a few packets sent. According
>>> to WireShark it's a "Tree Disconnect Request" with response and
>>> a "Logoff AndX Request" with response.
>>> Any idea what may be causing this?
To explain that further:

That was solved by mcafee Patch 7 for McAfee Enterprise 8.5

7.  ISSUE:
     Changes made in Microsoft Vista SP1 and later, in
     how the operating system opens/views network files,
     caused delays in opening new network paths, with
     the On-Access Scanner’s Network Scanning feature

     The link driver has been modified to use a
     different method of accessing the network resources
     that avoids the delays imposed by the operating
     system change.

Altough we use mainly XP we think that such a thing
caused the delays - we discovered it by simply removing
the virus scanner and tried to login with a roaming profile again -maybe
try that too

regards martin

More information about the samba mailing list