[Samba] printer drivers from windows 7 MMC?

Christ Schlacta lists at aarcane.org
Fri Dec 24 12:09:57 MST 2010

I didn't figure out how to add that permission.  is there a guide 
somewhere that lists all relevant permissions and how to set them?

turns out that a big part of the problem was related to changing the 
samba host SID.  that raises an interresting question which I'll ask in 
a separate post.

I still had to map drivers to printers using the command line, but other 
than that, it worked excellently to load drivers.

the process to map drivers is this easy:
rpcclient -c enumprinters  printserver
rpcclient -c enumdrivers printserver
sudo rpcclient -c 'setdriver <printer from 1> "<driver from 2>" density

but because of the permission problem above I had to run the last as 
root, which meant adding a password and re-enabling samba root account.

On 12/24/2010 08:20, Ryan Novosielski wrote:
> Hash: SHA1
> On 12/24/2010 03:32 AM, Christ Schlacta wrote:
>> I found a fancy, easy (seeming) way to add printer drivers in windows 7
>> since the old methods don't seem to work anymore.
>> if you run mmc, you can add a snapin called print management, which
>> enables you to manage various things (drivers, forms, ports, and
>> printers to be most important).  Problem is, I can't figure out how to
>> use the "Drivers" method to add drivers.  I get a "Failed to add driver.
>> Access is denied" error, can I can't figure fromwhere this error might
>> be issued.  my laptop is ikari, so I tried to less
>> /var/log/samba/log.ikari, but there were no errors relating to
>> permission being denied..  my user is a member of the samba group
>> "lpadmin", and the share has "write list = @lpadmin" and the directory
>> it points to is chmod g+s and chgrp -R lpadmin.  far as I can tell I can
>> write to this directory and there's no reason I shan't be able to
>> accomplish this except the mysterious access denied error.
>> I tried adding the (Apparently deprecated) printer admin = @lpadmin
>> option to the printer and print$ shares, but it didn't help.  I'll be
>> removing it.  my google-fu couldn't find the replacement attribute.
>> so the question is..  what do I need to do?  is windows 7 incapable of
>> doing this, or do I just need to somehow add the missing magic
>> permission somewhere?
>> PS: This isn't a member of a domain, it's not currently related to my
>> other domain issues, though the server will eventually be in the final,
>> completed domain)
> I could be on the wrong track here, but could the
> SePrintOperatorPrivilege that's set with the "net" command have anything
> to do with this (and if not that specific privilege, one of the others
> that is in the same set). That's been the right way to delegate
> permissions to a printer admin for some time, even before Windows 7.
> If that's all it is, thanks for the neat trick!
> - -- 
> - ---- _  _ _  _ ___  _  _  _
> |Y#| |  | |\/| |  \ |\ |  | |Ryan Novosielski - Sr. Systems Programmer
> |$&| |__| |  | |__/ | \| _| |novosirj at umdnj.edu - 973/972.0922 (2-0922)
> \__/ Univ. of Med. and Dent.|IST/CST-Academic Svcs. - ADMC 450, Newark
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> iEYEARECAAYFAk0UyGUACgkQmb+gadEcsb6QMQCdF5OqykkOIgN/i0lWO3YvyyYc
> VYoAoNGpp8YZI+KYAutek2AoyJ9Plsyt
> =XEkw

More information about the samba mailing list