[Samba] Samba 3.3.12/3.4.7/3.5.2 on "ancient" server stops responding/dies

Luca Olivetti luca at wetron.es
Fri Apr 30 08:48:56 MDT 2010

En/na Luca Olivetti ha escrit:
> En/na Luca Olivetti ha escrit:
>> En/na Luca Olivetti ha escrit:
>>> Each one of them has problems, the most "stable" of the three is 3.3.12.
>>> This one seems to work fine for a machine already in the domain 
>>> mapping shares to drives, but it hangs when trying to browse the 
>>> server or to add a machine to the domain.
>> I now tried both to rebuild 3.0.11 (to see if there is some problem 
>> with my build system), and it still works fine, and 3.3.0 (trying to 
>> bisect when the problem was introduced) and it still fails the same 
>> way with a slight difference:
> [...]
>> And smbd dies (with 3.3.12 it also died but not until the next query).
>> I'm going to try earlier versions.
> Up to now I've tried 3.0.37 (works fine) and 3.2.3.
> 3.2.3 still hangs a minute or so between the first and the second part 
> to the reply of smbclient -L *but* it completes the command, doesn't die 
> and otherwise seems to work fine.

After a long round of bisecting I found that the last working version 
(apart from the 1 minute delay) is 3.2.5.
I didn't find anything like this about 3.2.6 in the mailing list :-/

Luca Olivetti
Wetron Automatización S.A. http://www.wetron.es/
Tel. +34 93 5883004 (Ext.133)  Fax +34 93 5883007

More information about the samba mailing list