[Samba] krb5 library issues when Compiling 3.5.2 and 3.4.7 on AIX 5.3

Craig Green cgreen at ultradata.com.au
Fri Apr 16 00:57:58 MDT 2010

I have been trying to configure/compile Samba 3.5.2 and 3.4.7 on AIX 5.3 with ML-11 and ML-10.

The configure issues that I am getting only occur if I use --with-ads.
I can run configure on both versions if I do not include ADS support.

The errors I get are:

checking for krb5_principal_get_realm... no
checking for krb5_princ_realm... no
configure: WARNING: krb5_mk_req_extended not found in -lkrb5
configure: WARNING: no CREATE_KEY_FUNCTIONS detected
configure: WARNING: no GET_ENCTYPES_FUNCTIONS detected
configure: WARNING: no KT_FREE_FUNCTION detected
configure: error: krb5 libs don't have all features required for Active Directory support

It appears that I am missing the krb5-libs, is this correct?
If I do not include "--with-ads" I get the same WARNINGS but do not get the error.
The error is now actually a warning, as per:

configure: WARNING: krb5 libs don't have all features required for Active Directory support
checking whether Active Directory and krb5 support is used... no

I have also tried compiling KRB5 from source.  It compiles and I can install what I have compiled but I still get the same warnings and error.

I am using gcc, etc .from the pware.hvcc site.
The packaged I have installed are:

  pware53.autoconf.rte  COMMITTED  GNU autoconf 2.63
  pware53.base.rte   COMMITTED  pWare base for 5.3
  pware53.bdb.rte   COMMITTED  Berkeley DB 4.7.25
  pware53.bison.rte  COMMITTED  GNU bison 2.4
  pware53.cyrus-sasl.rte  COMMITTED  cyrus-sasl 2.1.23
  pware53.gcc-g++.rte  COMMITTED  GNU GCC
  pware53.gettext.rte  COMMITTED  GNU gettext 0.17
  pware53.gmp.rte    COMMITTED  gmp 4.3.1
  pware53.krb5.rte   COMMITTED  MIT Kerberos 1.7.1
  pware53.libiconv.rte  COMMITTED  GNU libiconv 1.13.1
  pware53.libtool.rte  COMMITTED  GNU libtool 1.5.26
  pware53.m4.rte    COMMITTED  GNU m4 1.4.12
  pware53.make.rte  COMMITTED  GNU make 3.81
  pware53.mpfr.rte   COMMITTED  mpfr 2.4.1-p5
  pware53.ncurses.rte  COMMITTED  ncurses
  pware53.openldap.rte  COMMITTED  OpenLDAP 2.4.21
  pware53.openssl.rte  COMMITTED  OpenSSL 0.9.8m
  pware53.popt.rte  COMMITTED  popt 1.10.4
  pware53.readline.rte  COMMITTED  GNU readline 6.1
  pware53.zlib.rte   COMMITTED  zlib 1.2.4

Here is my configure line

./configure --with-acl-support --with-utmp --with-ads \
--with-ldap --with-krb5=/opt/pware --with-pam \
--with-libiconv=/opt/pware --with-sendfile-support \
--prefix=/opt/pware/samba/3.4.7 --with-syslog --with-quotas \
--with-winbind=yes --with-aio-support=yes --with-automount \
--with-static-modules="vfs_aixacl2,vfs_aixacl" \
--with-shared-modules="idmap_rid,idmap_ad,idmap_tdb2" \

Does anyone have any idea as to what the problem is?


Craig Green
Support Consultant - Unix

Ultradata - Vision to Reality
+61 3 9291 1742

Disclaimer Notice

This message contains privileged and confidential information intended only for the use of the addressee named above. If you are not the intended recipient of this message you are hereby notified that you must not disseminate, copy or take any action or place any reliance on it. If you have received this message in error please notify Ultradata immediately on +61 3 9291 1600. Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Ultradata Australia Pty. Ltd.

To unsubscribe from receiving commercial electronic messages from Ultradata Australia please email unsubscribe at ultradata.com.au with the subject heading "Unsubscribe".

More information about the samba mailing list