[Samba] How to stop mount.cifs remembering password

Andy Gibbs andyg1001 at hotmail.co.uk
Mon Apr 12 07:23:04 MDT 2010

> IIUC it's due to the Kerberos ticket being cached.
> Have you tried issuing a kdestroy on it?

Thank you for your suggestion!

I discovered that I did not have kdestroy installed.  I downloaded and built 
it, but kdestroy returns the error:

"kdestroy: No credentials cache found while destroying cache"

I think I am not using kerberos however with mount.cifs, since doing 'cat 
/proc/fs/cifs/SecurityFlags' returns '0x7' (i.e. bit 4 indicating 'may use 
kerberos' is not set).  Attempting to set bit 4 (e.g. by 'echo 15 > 
/proc/fs/cifs/SecurityFlags') returns the error:

"CIFS VFS: attempt to set unsupported security flags 0x8"

I have also tried using the "-o noperm" and "-S" options in mount.cifs, with 
little difference.

I'm afraid I am not much closer to success, but I have learnt a lot more, so 
that is good at least!

Thanks again,


More information about the samba mailing list