[Samba] samba file locking

Janez Kosmrlj postnalista at googlemail.com
Fri Sep 25 06:14:45 MDT 2009

I encountered an interesting problem. We have a Java application on a samba
server. The folder is then shared to the clients via a samba share. So far
it works OK. Until now we had windows clients and everything worked OK. But
now we are trying to migrate to Linux clients and this is where the fun
starts. When a developer copies a new jar to the folder which is shared via
samba. And if this copying is done by scp strange things start happening.
After a few clicks the application stops working returning NoClassDeffFound,
even if the file is there and readable. After that it is not enough to just
stop the application, you have to unmount an then mount the share. I tried
turning off oplocks and then turning on kernel oplocks in the samba
configuration as suggested in the samba how-to, but it doesn't fix the
Has anyone an idea how to fix this situation?


More information about the samba mailing list