[Samba] doc & examples bug regarding 'xattr' special switch need

Mark Nienberg gmane at tippingmar.com
Tue Sep 15 10:57:07 MDT 2009

Linda Walsh wrote:
> This may already be fixed, but various places talk about the need
> for a 'user_xattr' switch on mounts to use extended attributes.
> I've never known 'xfs' to have such a switch -- if they are enabled
> in the kernel, they just work -- I tried it.
> I also tried adding the switch and verified it is not an accepted
> switch for XFS.   Is the documentation referring to some newer
> filesystem that has incompatible options (regarding external 
> attributes)?   
> I'm running a stock SuSE kernel and they are enabled by default (and
> fully available to non-root users).  

Another bit of minor confusion about this is that RedHat and CentOS (and probably 
Fedora and others) enable them by default too, without the switch in fstab.  I think 
it is because they are used by SElinux.

However, if you add another mountpoint and filesystem later (after installation), 
then they are not enabled on the new filesystem until you add the switch at mount 
time.  This results in the confusing situation of two mountpoints looking the same in 
fstab, but one having xattrs enabled and the other not.

My observations above are for ext3 filesystems.

I think the best advice may be to do a simple test on your filesystem to see if you 
can set and read extended attributes.  If you can, you are good to go.  If not, add 
the switch in fstab.

Mark Nienberg
Sent from an invalid address. Please reply to the group.

More information about the samba mailing list