[Samba] Compiling 3.4.0 on SPARC Solaris 9

Michael Wood esiotrot at gmail.com
Wed Sep 9 14:29:28 MDT 2009


2009/9/9  <Nigel.Pain at scotland.gsi.gov.uk>:
> I've been trying to compile Samba 3.4.0 on a Solaris 9 server. However,
> when I run configure, it is only creating a Makefile-noincludes, not the
> standard Makefile. Looking at the config.log file, there are lines that
> suggest that it can't find the libiconv libraries. These are installed
> (version 1.11) in /usr/local so I tried re-running configure with the
> option --with-libiconv=/usr/local. However, this also fails as conftest
> now will not compile.
> Thanks in advance for any suggestions.

3.4.1 was just announced earlier today.  One of the things it lists as
changed from 3.4.0 is:
   * Fix linking on Solaris.

Although that doesn't sound like the problem you're running into (I
don't think) it might be a good idea to try 3.4.1 anyway.

Also, perhaps if you paste the part of the config.log where the
libiconv test fails into your next e-mail someone will be figure out
what's wrong.

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list