[Samba] Rename Computer In Samba Domain: Access Is Denied

Bruno MACADRE bruno.macadre at univ-rouen.fr
Fri Oct 2 15:38:51 MDT 2009


    I've had a similar behavior in compiling 3.4.2 from scratch, not for 
the library path (--prefix works correctly on ./configure), but for the 

    I proceed like this : ./configure --prefix=/usr 
--sysconfdir=/etc/samba  --libdir=/usr/lib ....  (other options)
       make install

    But when I launch any tools compiled (testparm, pdbedit, smbd, nmbd, 
...) all are searching smb.conf into /usr/lib. After a few research, it 
appears that Mafefile contain CONFIGDIR=/usr/lib (and not /etc/samba 
like it must...) after changing CONFIGDIR in the Makefile and make, all 
works fine.

    Maybe your problem resides into the Makefile ? Have you try to to 
use some options into your "configure" (like --libdir) ?


m a écrit :
> Ah, thanks. I tested 3.3.8 and 3.4.2. On 3.3.8 the computer rename
> still fails with the same log symptoms, but on 3.4.2 the rename
> actually succeeds. I reckon this is a bug in the 3.2 and 3.3 series.
> As an aside, in compiling these versions from scratch I am puzzled by
> if the install scripts (make install) are expected to handle setting
> up shared library locations. i.e., the shared libraries are installed
> into /usr/local/samba/lib but the script doesn't appear to do any
> configuration to enable these to be found when the binaries are
> loaded.
> Is this intended to be beyond the scope of the makefiles? Looking
> around, things like Chapter 42 of the Samba How To (How to Compile
> Samba) talk about doing a make install and subsequently running the
> daemons as if there's no other steps to be dealt with.
> (I did manually set up my ld.so.conf to search the samba/lib directory
> but don't know if this should've been necessary.)
> On Thu, Oct 1, 2009 at 5:22 PM, Jeremy Allison <jra at samba.org> wrote:
>> On Thu, Oct 01, 2009 at 05:09:00PM -0700, m wrote:
>>> It still doesn't work and I tried the same on a different Samba
>>> installation which is version 3.3.2 and it behaved the same way. (Thus
>>> covering versions 3.2.3 and 3.3.2).
>>> I didn't mention before, this is with passdb backend = tdbsam.
>>> I've been continuing to study the issue and I think the relevant error line is
>>> <<
>>> [2009/10/01 16:59:35,  2]
>>> rpc_server/srv_samr_nt.c:access_check_samr_function(246)
>>>   _samr_SetUserInfo: ACCESS DENIED (granted: 0x000d04e4;  required: 0x000000b0)
>> Ah. Please upgrade to the latest 3.3.8 relesae which had
>> some work in this area (or 3.4.2).
>> Jeremy

More information about the samba mailing list