[Samba] strange issue with xerox printer: unable to configure driver

François Legal francois.legal at thom.fr.eu.org
Mon Nov 30 01:18:26 MST 2009


I've been having the same problem on a 7328 if I remember well.

The problem is that the Xerox driver uses some proprietary print
processor. Under windows, the print server is expected to run the print
processor (which is not possible with samba as the print processor is a

You have (as far as I know) 2 options here :
- Setup the printer in samba without specifying the driver (samba will
then only be used as a spooler for win clients). Point and print can then
no more be used
- Buy the postscript option from Xerox and use the print driver from cups
for the win clients


On Fri, 27 Nov 2009 18:32:58 +0100, Guillaume Rousse
<Guillaume.Rousse at inria.fr> wrote:
> Hello list.
> I've a strange issue with a samba 3.4.3 print server. Everything is fine

> with most printers, meaning drivers are assigned on server side and 
> automatically distributed to the clients as expected. However, I fail to

> configure a Xerox document center 7435 the same way.
> When I attempt to assign a driver to the printer, from a windows client 
> with admin privileges,  I get an 'unexpected error occured in the print 
> driver, close this windows and retry' error message, twice. More 
> precisely, I can see initial renaming of the printer according to the 
> driver name, then the error occurs, then the printer get renamed to '' 
> (which is a bit painful :P)
> I previously had a slightly different model (document center pro c2636) 
> which was working fine. The other working printers are not xerox ones.
> The driver is OK: it works fine when accessing the printer directly, and

> also when used from a windows print server. Also, I tried other variants

> (such as PCL driver instead of PS one), without success.
> When configuring the same printer from a Windows system, I had to 
> configure it with raw socket connection, because IPP connection didn't 
> allowed me to share it at all, and CIFS connection to the print queue 
> caused me some troubles (the printer didn't appeared in the 'fax and 
> printers list' of the server from remote hosts).
> The underlying printing system, cups, works perfectly. I've tried to 
> switch from IPP to raw socket connection, because of the behaviour 
> changes found with windows server, it didn't change anything.
> I performed a network capture both on server and client side while 
> triggering the error. The result is available as:
> http://www.zarb.org/~guillomovitch/server.pcap
> http://www.zarb.org/~guillomovitch/client.pcap
> I can see some suspicious messages such as:
> WINREG	OpenKey response, Error: WERR_BADFILE
> SPOOLSS	GetPrinterData response, PrintProcCaps_NT EMF 1.008, File not 
> found (pathname error)
> SPOOLSS	SetPrinterDataEx response, Access denied
> But nothing really useful.
> I'm joining my samba configuration file. I'm using mandriva 2009.0 as 
> server, and windows XP enterprise as client.
> Any hint appreciated.

More information about the samba mailing list