[Samba] Desiring to set up Windows Vista and Linux Fedora Core 4

Barry L. Bond bbond at cfl.rr.com
Fri Nov 20 23:28:31 MST 2009

Hi Michael!

     Thank you for your extra efforts to try to follow this, and with my
only having time to try something else once every couple of weeks!  :-O

On Sun, Nov 08, 2009 at 04:02:50PM +0200, Michael Wood wrote:

> It would be a lot easier for people to follow if you provided an ASCII
> art diagram of all the machine and routers involved, but I have drawn
> your network on a piece of paper based on your description.

     Okay...  :-)  I actually do need to "draw up" a better diagram than I
drew up when I had some network changes last year after a direct lightning
strike to my house!  :-)  (Until that lightning strike, I had a Cyclades
16-port PCI bus card in the Linux computer.  That was fried, and I went to
the IP Network hub, allowing the Solaris as well as the Linux to control
the ports.  I added the D-Link DGS-2205 switch then, too...)  I will plan

> It seems your Linux box only has one network card, right?  And are you
> trying to print from the Windows machine connected to your D-Link
> router?  Or from a Virtual machine running under VMware on the Linux
> box?

     Correct.  The Linux box has only one network card, and it is attached
to the DGS-2205 (switch).  One network port on the Sun is attached to the
D-Link router and the cable modem is on the other side of that, and
another Sun network port is attached to the DGS-2205 switch.

     The only network port of the Windows is attached to the D-Link

     I'm trying to print from the Windows machine connected to the D-Link

     Well, forget the virtual machine, really, for now.  (In the past, I
have run Windows 98 through VMware running on the Linux, and I was able to
do on it exactly what I WANT to do with this truly separate Windows
machine:  print and transfer files.  Back then, I had TIME, and I likely
just "trial-ed and error-ed" until I got it working well enough!)

> Your interfaces line appears to specify all possible interfaces other
> than lo anyway, so you may as well leave it out.

     Really, the vmnet interfaces could go now... I just had left them,
for they were needed and used in the past (and there is a slight chance
they MAY be used in the future), and I didn't think they hurt anything.
Is that okay?

> [...]
> >> >        printcap name = /etc/printcap
> [...]
> >> >        cups options = raw
> >>
> >> Are you using cups?  The "printcap name" above leads me to believe you
> >> are not using cups.
> >
> >     Yes.  :-)  Who knows... when I first set up my FC4 Linux system, I
> > wasn't using cups, but I installed it soon afterward.  That may have been
> > leftover from then, but it was working!  :-)
> Well, if you are using CUPS, you could set up an IPP printer on the
> Windows box and bypass Samba completely.  In the "Add Printer Wizard"
> you tell it to add a network printer and on the next screen choose the
> "Connect to a printer on the Internet..." option (XP.  Not sure if
> it's the same for Vista).  The URL should be something like:

     Er... no I can't.  This printer has only a parallel port, and it is
attached to a parallel port on my Linux computer.  :-)

> (depending on what name the printer has been given in CUPS.)
> Try browsing to on the Linux box to see if CUPS is running.

     It most certainly is.  I don't use "this type of interface" very
often, but I have accessed it this way some.  (I usually just "lp" and

     I print quite a bit from the Linux system, via my CUPS-enabled HP
9110 printer.

> [...]
> >     I just typed "\\\HP9110" in the text box and I clicked the
> > [Next] button.
> >
> >     The dialog box says "Connecting to HP9110 on"...
> >
> >     After a delay, it eventually brings up another dialog box that says
> > "Windows cannot connect to the printer.  Make sure that you have typed the
> > name correctly, and that the printer is connected to network."
> Perhaps you should see if you can telnet to the TCP ports mentioned by
> Eero from the Ultra 30.  It would be better to test from Vista, but
> I've been told Vista does not have a telnet client built in.
> Otherwise you could download something like PuTTY and see if you can
> connect to those ports from the Vista machine.

     Hmmm.... so, on the Sun, type "telnet" and whatever port?
I'm using that IP because that's the Linux system, where the Samba is

     If that's what you mean, then here is what I get:

bash-2.03# telnet 135
telnet: Unable to connect to remote host: Connection refused
bash-2.03# telnet 137
telnet: Unable to connect to remote host: Connection refused
bash-2.03# telnet 138
telnet: Unable to connect to remote host: Connection refused
bash-2.03# telnet 139
Connected to
Escape character is '^]'.


     I never enabled "ftp" on my Linux system, so I guess that's why I'm
getting "Connection refused" on most of the attempts.

     When I tried with port 139, it displayed what you see, and there was
a delay for a couple of minutes, and then I see:

Connection closed by foreign host
bash-2.03# telnet 445
Connected to
Escape character is '^]'.
Connection closed by foreign host

     There is also a delay after the port 445 and then I saw the
"Connection closed by foreign host" message.

     Is this what you had in mind?

> >     The first rpm gave me "cups-1.1.23-15".  The second one (with /sbin)
> > said "No such file or directory".
> OK, so it seems that CUPS is installed.  Or at least part of it.
> What does "rpm -qa | grep cups" give you?

     That command gives me:

[root at barrycon xinetd.d]# rpm -qa | grep cups

> >> See if the Windows box can resolve the name of the Linux box:
> >>
> >> C:\>nbtstat -a barrycon
> [...]
> >     It says:  "Local Area Connection:
> >                Node IpAddress:  [] Scope Id:  []
> >
> >                      Host not found."
> OK, so name resolution is not working.  This is likely because you
> have the Windows box and the Linux box on different subnets.  You
> could try configuring the Windows box to use the Linux box as a WINS
> server.  Samba would have to be running as a WINS server.

     Ah... well, I also asked Eero if that was a problem...  I would be
happy using IP addresses, but we can keep this in mind...

> >> It should show the IP address and then a "NetBIOS Remote Machine Name Table".
> >>
> >> Also try:
> >>
> >> C:\>nbtstat -A 192.168.x.y
> >>
> >> (with the IP address of the Linux machine.)
> >
> >     I'm typing "nbtstat -a"...
> >
> >     ...and it says EXACTLY the same thing, after a slight delay.
> Note the capital A in my command.  When you query an IP address using
> nbtstat you need -A instead of -a.

     Ah!  I apologize about that!  Let me try it again!

     Typed carefully... since I am typing instead of copying/pasting it!

C:\Users\Barry L. Bond>nbtstat -A

Local Area Connection:
Node IpAddress: [] Scope Id: []

    Host not found.

     (I may have typed the capital A in Windows before and typed it as a
lowercase a in email, but I'm sure not going by memory!)  :-D

> OK, so either you have a firewall blocking this (e.g. on the Ultra 30
> or on Linux) or the Window box does not know how to get to the
> network.  If it's the latter, add a route for
> netmask to the Windows machine's network
> settings with a gateway of (the IP of the Ultra 30 on
> the 192.168.1.x subnet).

     I don't have a firewall running on the Ultra 30 or the Linux.  The
D-Link router is also a firewall, for the Internet side.

     Okay.  I'm noting this.  I have absolutely no idea how to do this!
:-)  But, I shall add it to my "do list"...

> Also check that you can ping from the Window box.

     This worked:

C:\Users\Barry L. Bond>ping

Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=255
Reply from bytes=32 time<1ms TTL=255
Reply from bytes=32 time<1ms TTL=255
Reply from bytes=32 time<1ms TTL=255

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 <0% loss>,
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

     Thank you, Michael!  I appreciate and need your help!


Barry L. Bond                      | http://home.roadrunner.com/~os9barry
Software Engineer, ITT Corporation | (My personal home web page, last
                                   | updated February 17, 2005)
bbond @ cfl.rr.com <- personal     |  Re-Vita Products:
Barry.Bond @ ITT.com <- Work ONLY  |  http://www.re-vita.net/barrybond
                                   |  Re-Vita Distributor Information
Home office:  407-382-2815         |  http://www.re-vita.net/barrybond-2
Work:         321-494-5627 (Work)  |  Toll free order:  1-888-820-5531

More information about the samba mailing list