[Samba] Problem with Samba 3.4.3 - previous 3.3.x worked fine

Karl Denninger karl at denninger.net
Sat Nov 14 10:51:42 MST 2009

The explicit declaration of the passdb back end fixed the authentication
problem, but the printer connection issue remains.

I get NOTHING in the log files indicating a problem.  Here's what
"testparm" returns:

FS# ./testparm
Load smb config files from /usr/local/samba/lib/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[faxserver]"
Processing section "[pics]"
Processing section "[Music]"
Processing section "[Archive]"
Loaded services file OK.
Press enter to see a dump of your service definitions

        workgroup = DENNINGER
        server string = Denninger FileServer
        interfaces =
        passdb backend = smbpasswd
        log file = /var/log/log.%m
        max log size = 50
        deadtime = 15
        logon path = \\%L\Profiles\%U
        logon drive = Z:
        logon home = \\%L\%U
        os level = 35
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        ldap ssl = no
        remote announce =
        invalid users = root
        hosts allow =, 127.
        printing = bsd
        print command = lpr -r -P'%p' %s
        lpq command = lpq -P'%p'
        lprm command = lprm -P'%p' %j

        comment = Home Directories
        read only = No
        browseable = No
        browsable = No

        comment = All Printers
        path = /disk/spool/samba
        printable = Yes
        browseable = No
        browsable = No

        comment = Fax Server Files
        path = /disk/system
        valid users = karl
        read only = No
        create mask = 0765

        comment = Picture files
        path = /pics
        valid users = karl
        read only = No
        create mask = 0765

        comment = Music
        path = /archive/CD-Jukebox
        write list = @music-write
        read only = No

        comment = Archive
        path = /archive
        valid users = karl
        read only = No

I am running as a "workgroup" as the domain overhead doesn't appear to
be worthwhile in my application.

Unix printing works, and so does printing from Windows XP clients
(including "adding" the printers on the network to a windows machine as
a network printer.)  I have no VISTA clients, but the Windows 7 machines
cannot connect to printers - they connect to file shares just fine.

Dale Schroeder wrote:
> passdb backend default changed in 3.4 to tdbsam.  If you did not have
> it explicitly declared, you now have to say
>    passdb backend = smbpasswd
> I can't comment specifically to your printing issues.  3.4 did alter
> the printing subsystem, which may be the source
> of your problem.  I had several printers whose PCL5 drivers no longer
> worked.  I resolved by either upgrading to
> the latest driver or switching to PS drivers.  However, that does not
> explain your problem with Win 7.
> http://www.samba.org/samba/history/samba-3.4.0.html
> Dale
> Karl Denninger wrote:
>> Hi folks;
>> I have an odd one.
>> I recently upgraded from 3.3.x to 3.4.3 and suddenly lost both the old
>> "smbpasswd" file AND the ability to connect to printers from Windows 7
>> clients.
>> File server is fine, and everything else is working - I can connect to
>> printers from XP machines, but not from Windows 7 any more.
>> I get an "0x00000000d" error from Win7 when I try to connect.... no
>> further info available that I can find on what that is.
>> Ideas?
>> -- Karl Denninger
> %SPAMBLOCK-SYS: Matched [samba.org], message ok

More information about the samba mailing list