[Samba] Client driver installation

Matt Richardson marichar at csusb.edu
Fri May 29 22:56:45 GMT 2009

Gary L. Greene, Jr. wrote:
> I've an OpenSuSE based server installed at work that uses Samba to share out the
> prrinters for our users on the AD that will be replacing our aging Windows 2000
> print server. I'm in the process of getting the printer drivers installed for
> Windows clients. At present, I'm installing the drivers for the RICOH Aficio we
> have. When I run the following command: 
> printmaster:/var/lib/samba/drivers/W32X86 # rpcclient -U ggreene -c
> "adddriver 'Windows NT x86'
> 3" printmaster
> I get the following output:
> result was

Posting mostly to put some more info in the mailing list archive on this 
issue.  Some magic happened, so I'm afraid this may not be of much help.

I had a similar issue setting up a couple of HP LaserJet printers last 
week using cupsaddsmb.  The CUPS queue used HPLIP drivers and the CUPS 
postscript drivers listed in the cupsaddsmb man page were installed in 
/usr/share/cups/drivers.  The system is Debian Lenny with samba 
3.2.5-4lenny2 and cups 1.3.8-1lenny5.  It is an AD member server with 
all the winbind goodness working.  OK, hope that wasn't too verbose.

The output showed adddriver succeeding and setdriver failed 
WERR_INVALID_PARAM.  Trying to do it manually with rpcclient adddriver 
succeeded, but setdriver failed with the error 
WERR_UNKNOWN_PRINTER_DRIVER.  From the CUPS web interface, exporting 
printers to samba returned a success message, but in reality only the 
adddriver had succeeded, still no setdriver success.  Just because 
nothing else seemed to be working, I changed permissions to 777 for the 
/var/lib/samba directories where all the printer stuff was supposed to 
land.  Still no joy.

After leaving it for a few days, I got back to it yesterday, dumped the 
print queues from CUPS and readded one.  enumprinters showed samba 
recognized the queues.  From the CUPS web interface, export printers to 
samba reported success.  Verifying that with enumprinters and 
enumdrivers showed that it had indeed succeeded.  Adding the second 
queue to CUPS, enumprinters would not show the second queue.  Go through 
the usual stop and start of services, enumprinters then sees the second 
queue.  Exporting to samba from CUPS web interface succeeds and 
enumdrivers verifies this to be true.

 From the client, connecting to \\myawesomesmbserver\myawesomeprinter 
succeeds, no dialogs about the server not having the driver, and I can 
print a test page.  Now there is joy.

So the magic happened somewhere between Friday afternoon when I quit 
working on it and yesterday when I got back to it and did the same thing 
I had tried previously.  While I do want to know what occurred, I am 
happy for the moment with knowing that I can now add print queues to 
samba with drivers.  I need to set up quotas, so raw printing isn't 
going to cut it.


Matt Richardson
IT Consultant
College of Arts and Letters
CSU San Bernardino
work: (909)537-7598
fax: (909)537-5926

More information about the samba mailing list