[Samba] NFS mounted samba share

Daniel Bourque dbourque at weatherdata.com
Thu May 28 15:19:46 GMT 2009

Guess I spoke too fast, although I no longer have any issue using 
smbclient, from windows 2000 / XP  , the problem still exists.

same NFS mount point works fine through a samba-2.2.3a-6 install.... 
pullling my hair out !


Daniel Bourque wrote:
> That fixed it. Thank you so much.
> I had tried to disable oplocks , that didn't work. I should buy myself 
> an RTFM mug...
> I agree that it's not the best idea, it's a temporary way to move data 
> from server to server with breaking user's mappings. I'll change their 
> mappings in their login scripts.
> Daniel Bourque
> Sr. Systems Engineer
> WeatherData Service Inc
> An Accuweather Company
> Office (316) 266-8013
> Office (316) 265-9127 ext. 3013
> Mobile (316) 640-1024
> Volker Lendecke wrote:
>> On Wed, May 27, 2009 at 10:38:00AM -0500, Daniel Bourque wrote:
>>>    I'm sharing an NFS mounted directory via samba. When a client 
>>> connect to the share, he can browse it fine, but any attempt to read 
>>> data, like copying or looking that the file's properties results in 
>>> a lockup on the client, and an eventual time out. On the server, a 
>>> lock ( DENY_NONE  0x120089    RDONLY     NONE ) is created an never 
>>> goes away, even after the client as disconnected.
>> Please don't re-export NFS imports via Samba. This is not
>> really supported exactly due to the problems you mention.
>> If you absolutely must do this because for example your
>> NetApp NFS server does not have CIFS enabled, you might want
>> to try setting "posix locking = no" in your smb.conf. This
>> works around bugs in your NFS client and means
>> cross-protocol locking is not done.
>> Volker

More information about the samba mailing list