[Samba] AD 3.3.x issues

Kristian Davies kristian.davies at gmail.com
Tue Mar 24 13:52:14 GMT 2009

I have a 3.2.8 samba server (centos4) connected to AD which works perfectly.

My other machine 3.3.0 was suffering from a bug where MAC users would
copy a file to the network and would get an error message regarding
permissions, which I tracked down to it creating ._files and putting
MAC permission on files, which 3.2.8 doesn't do.  Unable to solve that
I upgraded to 3.3.2 which did solve the issue but left me with
another.  The user logs in locally, but the machine is part of an old
NT domain.  Before I upgraded the samba server it was using 3.3.0 but
worked fine for this user.  Now on 3.3.2 I get errrors like
"domain_client_validate: unable to validate password for user DAVE in
domain MACHINENAME to Domain controller myserver.ad.domain.local Error
was NT_STATUS_NO_SUCH_USER."  This happens even if you \\samba\share
and use domain\DAVE...  still get the same error like it's expecting a
trust relationship all of a sudden.

./configure --prefix=/disk1/samba --with-ads --with-krb5  --with-pam
--with-winbind --with-syslog --with-quotas --with-acl-support
--with-automount --with-cifsmount --enable-socket-wrapper
--with-configdir=/etc/samba --with-logfilebase=/var/log/samba


More information about the samba mailing list