[Samba] ACL problem under FC9

Christos Karaviotis chris at linuxcyprus.org
Fri Mar 13 08:07:04 GMT 2009

On Wed, March 11, 2009 14:26, Adam Tauno Williams wrote:
>> I am running Samba for some years now (3 years) and had absolutely no
>> problems.  For the last month on one of the machines the NT ACL stopped
>> working and everyone have full access everywhere even if they are not in
>> the acl.
>> If I try to add them and restrict them only to read and execute the acl
>> will show that this is the case but it will have no effect.
>> I am running Fedora 9 and Samba-3.2.4.  I have done the installation
>> many
>> times and this particular one used to work but now it fails.
>> I have tried to upgrade to 3.2.8 but still the same problem.  I have
>> remounted the FS with the option (acl) it did it but that did not solve
>> the problem.
> If you do a getfacl on the object do you see the ACLs you think you set?
> --
> OpenGroupware developer: awilliam at whitemice.org
> <http://whitemiceconsulting.blogspot.com/>
> OpenGroupare & Cyrus IMAPd documenation @
> <http://docs.opengroupware.org/Members/whitemice/wmogag/file_view>
Well I did that.  Even users that do not exist in that folder's ACL have
rwx effective permissions.  I am going crazy.  The same exact setup with
the same permissions on another machine is still working fine.


More information about the samba mailing list