[Samba] Migration from samba-3.0.21b-i486 to samba-3.0.27a-x86_64 corrupts root group mapping

damjanster damjan.ziberna at abakus.si
Wed Jun 24 10:52:08 GMT 2009


I went and copied the config files from <source>/etc/samba/* and
<source>/var/cache/samba/* to the target server and deleted the browse.dat
and wins.dat files. The source and target servers have different IPs and
hostnames, so we use "netbios alias". This has worked fine a couple of years
ago. Now after all files have been copied, the old server shut down and the
new samba in place there are several differences between the systems:
$pdbedit -vL root
Unix username:        root
NT username:
Account Flags:        [U          ]
User SID:             S-1-5-21-528702806-1563566892-1083768929-1000
Primary group for user root is a Local Group and not a domain group
Primary Group SID:    S-1-5-21-528702806-1563566892-1083768929-513
the Primary Group SID is wrong. It should end with 512 (Domain Admins) -
here it becomes -513 (Users) - all the permissions are therefor corrupt - no
admin can login via windows XP clients.

I have a test server where I've put all the linux user/group files from the
source server and tried to place the same samba server there, but the result
is exactly the same.

net getlocalsid doesn't work on the source server (previously migrated from
even older server)
net getlocalsid <DOMAINNAME> returns the same value on source and target
net groupmap list shows a lot more groups on source server then target.

What else can I try? 
View this message in context: http://www.nabble.com/Migration-from-samba-3.0.21b-i486-to-samba-3.0.27a-x86_64-corrupts-root-group-mapping-tp24182571p24182571.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list