[Samba] Only administrator works in ldapsam:editposix domain

Kyle Schmitt kyleaschmitt at gmail.com
Mon Jul 20 14:43:21 MDT 2009

I tried setting up a samba/ldap domain using the ldapsam:editposix
feature, using the brief instructions at

Everything goes rather smoothly, and I can add XP machines and log
into them as the Administrative user.

I added a user to the server, then to samba/ldap using smbpasswd -a newuser
ldapsearch -x shows the user & encrypted password, so I figure I'm good to go.

When log in with my new (non admin) user, I get an error about
catastrophic failure,
"Unable to complete the requested operation because of either a
catastrophic media failure or a data structure corruption on the

Hu, maybe the user isn't in the domain users group yet?

net rpc group addmem "Domain Users" newuser
Could not add newuser  to Domain Users: NT_STATUS_NO_SUCH_MEMBER
I tried a bunch of variations with the domain before one part or
another, and got pretty much the same error messages over and over.

What am I doing wrong?

More information about the samba mailing list