[Samba] SMB Signing issues... smbclient works, mount does not...

Julian Houghton sarlacii at yahoo.com
Sun Jan 25 18:35:15 GMT 2009

Greetings Samba peoples... apologies for the long post.

I have an issue that remains unresolved on my usual forum, linuxforums.org... it relates to SMB Signing when connecting from Linux to a Win 2003 file server.

My OS:
>> PClinuxOS - a Mandriva derivative
My Samba versions:
>> samba-client-3.0.30-3pclos2007.i586.rpm
>> samba-common-3.0.30-3pclos2007.i586.rpm
>> samba-doc-3.0.30-3pclos2007.i586.rpm
>> samba-server-3.0.30-3pclos2007.i586.rpm

When attempting to mount a remote share, "mount -t smbfs //server/share /mnt/dir -o username=user,password=pass" I get the following error:

cli_negprot: SMB signing is mandatory and we have disabled it.
14216: protocol negotiation failed
SMB connection failed

When I try smbclient... "smbclient //server/share -U user" and enter my password, smbclient connects without issue.

I have tried to solve things, but have come across a void in the help files, man files and online postings with regards to SMB Signing. LOL I was especially mystified to learn from a posting on your mail-list that there is an undocumented smbclient switch ("-S", i.e. capital "S") which can be used to enabled or disable SMB signing at the command-line. Why is this switch not in any of the man files???

Anyway, using "smbclient //server/share -U user -S off" results in the exact same error message quoted above, as you would expect. If I use "-S on" however, smbclient connects properly.

In an effort to get the mount command to work, I have assumed that smb.conf is the reference that mount.smbfs uses. I have tried all the various combinations of "server signing = <x>" and "client signing = <x>" (where <x> is either Auto, Mandatory or Disabled as per the man file and other refs for smb.conf). I have even tried "on" and "off". Nothing works... mount, via mount.smbfs, always gives the SMB Signing error. It's like it isn't reading the config file.

Any help on this issue would be appreciated, especially info on what variables mount.smbfs reads and what the -S hidden switch really does.

Also, please note that I am aware of cifs... using cifs in the mount command also fails, with:

mount error 13 = Permission denied
Refer to the mount.cifs manual page (e.g.man mount.cifs)

Which the /var/log/messages (and dedug etc.) file tells you is because of SMB Signing failures... didn't note the exact error down, but was something about an unexpected SMB signature.

I am hoping that since smbclient works I should be able to get mount via smbfs to work too.



Respectfully... Sarlac II

The moving clock of K` appears to observer K
to run slow by the factor (1-v2/c2)^(1/2)
relative to the stationary clocks in K.
This is the phenomenon of time dilation.

The faster you run, the younger you look,
to everyone but yourself.

To reply, remove "nospam"...
Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html


More information about the samba mailing list