[Samba] open_directory: unable to create *. Error was NT_STATUS_OBJECT_NAME_COLLISION

fbc flexbumpchest at gmail.com
Tue Jan 20 21:44:09 GMT 2009

Hi, I'm having problems moving/renaming files as a member of.  I tried to
move "test.txt" from "\\files\public\" to "\\files\public\OfficeWork".
Here's the error I get in windows:
*Cannot move test: access is denied.
Make sure the disk is not full or write-protected and that the file is not
currently in use.*
Here's the error log:
*[2009/01/20 15:10:34, 2] smbd/open.c:open_directory(2092)
  open_directory: unable to create OfficeWork. Error was

List of permissions in my \\files\public\ directory (ls -al):
drwxrwx---  9 officeuser1       local_office     4096 2009-01-20 15:14
-rwxrwx---  1 officeuser1       local_office        0 2009-01-20 15:28

The relavent part of my smb.conf:
        workgroup = OFFICE
        netbios aliases = FILES
        server string = Samba Server v%v
        security = DOMAIN
        passdb backend = tdbsam
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
        passwd chat debug = Yes
        username map = /etc/samba/smbusers
        unix password sync = Yes
        log level = 2
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 50
        printcap name = CUPS
        add user script = /usr/sbin/useradd -m '%u' -g users -G users
        delete user script = /usr/sbin/userdel -r %u
        add group script = /usr/sbin/groupadd %g
        delete group script = /usr/sbin/groupdel %g
        add user to group script = /usr/sbin/usernod -G %g %u
        add machine script = /usr/sbin/useradd -s /bin/false/ -d
/var/lib/nobody %u
        logon script = %U.bat
        logon path = \\%L\profiles\%U\%a
        logon drive = H:
        domain logons = Yes
        os level = 255
        preferred master = Yes
        domain master = Yes
        wins support = Yes
        ldap ssl = no
        idmap uid = 15000-20000
        idmap gid = 15000-20000
        template shell = /bin/bash
        profile acls = Yes
        cups options = raw
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192
        time server = yes
        hide dot files = yes
        invalid users = bin deamon sys man postfix mail ftp
        admin users = george.alexander
        smb ports = 445
        vfs object = audit
        domain admin group = @smbadmin
        domain admin users = root

        comment = files
        path = /home/samba/envision_files
        valid users = @local_office
        write list = @local_office
        writable = Yes
        create mask = 0770
        directory mask = 0770
        public = No*

Here's the user's line in /etc/passwd:

Here's the local_office group's line from /etc/group:

I've also tried specifying the comma separated usernames after "502:", with
no better results.

Both files are 770, owned by my group (local_office), and my group is in the
"write list" for the share, so what the heck is going on?
I've also tried increasing the log level, but that seems to give me even
fewer details about what's going on.
Anybody have any ideas?  Where should I start!? Thanks!

More information about the samba mailing list