[Samba] Calling Samba print server with an aliased DNS-name fails with Samba 3.2.7 but worked with 3.0.30.

Remy Zandwijk remy.zandwijk at falw.vu.nl
Thu Jan 15 19:24:57 GMT 2009

I investigated this problem and it's a bug. Refer to:



> Tonight, I upgraded our Samba print server running Samba 3.0.30 to Samba 
> 3.2.7. This netbios name of this server is 'EUPRYMNA' and the DNS-name 
> 'euprymna.falw.vu.nl'. Since this is a difficult name to remember, we 
> created a DNS-alias 'printserver.falw.vu.nl'.
> Connecting to printers by calling the server by it's DNS-alias worked in 
> 3.0.30. After the upgrade however, we can only connect to printers when 
> the server is called by it's normal DNS- or netbios name. When 
> connecting to the DNS-alias name of the server, the server responds with 
> 'Windows cannot connect to printer ....'.
> Looking at the level 10 logs, Samba is calling the 'is_myname' function 
> from lib/util.c. The parameter is the name the server is called with, in 
> my case 'printserver.falw.vu.nl'. is_myname returns 0, meaning the names 
> do not match.
> I found that setting 'netbios alias' to 'printserver.falw.vu.nl' is 
> resolving this issue, although nmbd complains about the name being too 
> long. is_myname returns 1, meaning the names match.
> Is this expected behaviour? Is there a better workaround available? If 
> needed, a level 10 log is available.
> -Remy

More information about the samba mailing list