[Samba] Samba performance issue

Fabien azertyzero at free.fr
Thu Jan 1 18:35:06 GMT 2009

Hello, I sent the following message to the Debian folks.

They don't think that the Debian packaging could be responsible for the
issue described there.

  > Well, I'm not completely convinced that we will have very useful input
  > for you. I don't really see any reason for this to be caused by the
  > Debian packaging. To check this, why not compile samba from sources,
  > install it in /usr/local and run the same tests?
  > I also recommend you bring this problem in the samba users mailing
  > lists (samba at lists.samba.org seems appropriate).

I must say I didn't try to compile it from the upstream sources for many

Anyway, I think that there is poor chances for the issue to be related
with the Debian package.

Thank you in advance for your advices ;)

Happy new year ! (yeah, it depends on where you are in the world !!)




sorry to write directly to you, but after long hours spent trying to
solve this strange problem, I thought it could be handled better by
speaking directly with you. I hope I'm not wrong...

While testing samba speed on my file server, using a fully tested
gigabyte ethernet connexion, I encontered some very strange performance

I had big speed differences when using samba locally, or via the network

"Mb" stands for Mbytes.
* My server config :
    - AMD X2 4200+
    - 2 Go RAM
    - 4 x 500 Go --> RAID5
    - Gigabyte connection
    - Debian ETCH
    - debian package : Samba 3.0.24 (I also tried to backport the testing
version => 3.2.5 but the results were exactly the same)

* My samba share folder is a partition of my RAID 5 (reading : 170 Mb/s
& writing : 90 Mb/s).

* Here are my benchmarks (nearly the same from Linux or Windows) :

- Reading via ftp on the server (no samba) from a Gigabyte client :
    => 120Mb/s
- Reading on the samba server from a Gigabyte client
    => 35Mb/s

- Writting via ftp on the server (no samba) from a Gigabyte client :
    => 90Mb/s
- Writing on the samba server from a Gigabyte client :
    => 40Mb/s

I also noticed that if I try to read/write on the samba server from more
than just one client, the results is exactly the same : the server
bandwith limit is 35(up)/40(down) Mb/s.

/!\ When I mount the samba partition localy (on the server) I can read
at 115 Mb/s or write at 90 Mb/s, which is the good behavior.

I tried MS Windows and Linux (etch) smbfs clients.

I did a lot of testing, using a 1Go RAM disk on both sides to avoid
disks problems, and got the same test results.

Do you think that the problem could come from the Debian package ?

I investigated google a lot and found very few people reporting this
strange behavior (mainly from ubuntu forums). I am pretty sure that
several (every ?) people, at least from debian, are concerned. I think
that they just didn't notice the speed problem (35Mo/s is still quite
nice to be noticeable).

I found some people trying to tweak the samba buffers : they only got a
little better speed (+ 5Mo/s).

My smb.conf file is attached.

Thanks for your help.



-------------- next part --------------
	workgroup = MSHOME
	server string = zeus
	interfaces = eth1
	bind interfaces only = Yes
	security = SHARE
	guest account = sambauser
	name resolve order = host wins bcast
	load printers = No
	os level = 0
	preferred master = No
	local master = No
	domain master = No
	invalid users = root
	force group = sambashare

	comment = private_data
	path = /data1
	read only = No
	create mask = 0770
	directory mask = 0770

	comment = common_data
	path = /data2
	read only = No
	create mask = 0775
	directory mask = 0775
	guest ok = Yes

More information about the samba mailing list