[Samba] Samba ignores printer options when printing via CUPS

David Meakins samba-list at judcom.nsw.gov.au
Mon Feb 23 06:27:44 GMT 2009

Hi all,
    I'm having a few problems getting samba to pass along settings for 
various print options for all of our printers. Printers are set up using 
PPDs in CUPS, added to samba via the cupsaddsmb command and then added 
to windows clients via point and print. Unfortunately any print jobs 
sent from windows appear to completely ignore many of the CUPS settings 
such as duplex and print tray assignments. If I try printing from Linux 
to CUPS then all duplexing and print tray options are honoured by the 
print server. Anyone come across this before?

    The long version - I've set up an Ubuntu 8.10 server with CUPS 
1.3.9-2ubuntu3 and samba 3.2.3-1ubuntu3.3 on it. The CUPS server has had 
several network printers added to it using both the manufacturer PPDs 
and several PPDs from linuxprinting.org via the web interface.

    For example, I've added a HP 4100 using the manufacturers PPD, and a 
HP 4250N using the PPD from linuxprinting.org. Both of these printers 
have a duplexer, and the 4250 has a second tray installed.

    I then set the printers various options via the web interface of 
CUPS, such as paper sizes, duplexing and extra print trays.

    I've gotten the CUPS drivers from the website ( 
http://www.cups.org/software.php ) specifically the Windows Driver files 
from this archive:

    The following files from that archive were installed into 

    I then got the following windows postscript files from a windows 
client and installed them into the same directory, renaming them to the 
lowercase version of their filename

    Edited smb.conf to add CUPS printing
  printing = cups
  printcap name = cups

   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700
   use client driver = no

   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
   write list = root, @admingroup

    Ran the commands to import CUPS printers into samba
cupsaddsmb -U Administrator -v printer_4100
cupsaddsmb -U Administrator -v printer_4250

    Let samba know that Administrator and our admin group have printer 
net -U Administrator rpc rights grant Administrator SePrintOperatorPrivilege
net -U Administrator rpc rights grant admingroup SePrintOperatorPrivilege

    Navigated to our print server and tried to connect via point n print 
by double clicking on a printer. This successfully added the printer and 
I was able to print test pages in windows.

    I then changed several of the default options on printers via right 
clicking printer name on the server -> properties -> Advanced -> 
Printing Defaults so that we print A4 by default and duplex by default. 
Also set postscript options to be "Optimise for portability".

    Checked this by logging on to a different windows box, and 
connecting via point and print and checking that all options are set. 
All settings were carried across fine.

    Tried to print duplex to both printers. This was successful.

    Tried to print simplex to both printers. This fails. Tried to print 
to a different paper tray than the default on a printer with multiple 
paper trays installed. This fails.

    Tried to upload the manufacturers PS driver for the printer, this 
was successful and I changed the various printer options. From windows 
still fails to print simplex if CUPS is set to default duplex, and fails 
to print to a different tray than default. Can successfully print duplex 
and simplex, and choose paper tray when printing from linux to CUPS.


| Judicial Commission of NSW | Ph: +61 2 9299 4421 | Fax: +61 2 9290 3194 |

This Message is intended for the addressee named and may contain confidential information. If you are not the intended recipient, please delete it and notify the sender.

Views expressed in this message are those of the individual sender and not necessarily the views of the Judicial Commission of NSW.

More information about the samba mailing list