[Samba] Time capsule and "bad smb"

Volker Lendecke Volker.Lendecke at SerNet.DE
Tue Feb 17 01:18:35 GMT 2009

On Mon, Feb 16, 2009 at 05:01:53PM +0100, Pietro Battiston wrote:
> Some update to the mail below: if I understand correctly, there are two
> different problems showing up:
> 1) mount.cifs and the Time Capsule (I have no idea on which front the
> problem is) don't seem to be able to handshake correctly if the share
> name contains whitespaces. I didn't notice at first glance, but then found
> some "no such share" errors in dmesg - not reported as output of the
> command. Then I tried to change the share name (on the Time Capsule,
> obviously) to a single word and reconnect, and it worked (almost, keep
> reading).
> 2) on some particular smb commands - please bear with me if what I say
> is somewhat imprecise - the Time Capsule sends back packets badly
> formatted (or that mount.cifs thinks are badly formatted). This happens,
> in particular:
> - for some packets that report an error, such as the "no such share"
> - for some packets during the unmount

Without a sniff we can't say who is wrong. But very likely
you will need to contact your Apple support to get your Time
Capsule box a decent CIFS server.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20090217/d0c23030/attachment.bin

More information about the samba mailing list