[Samba] The way things used to work...

Walter Mautner retlaw.rentuam at gmail.com
Mon Feb 16 22:18:34 GMT 2009

Am Monday 16 February 2009 21:00:04 schrieb Dragan Lukic:
> OK, I might not be a most polite person, but for sure I am not rude. Do
> have in mind that english is not my native language, and as I am not using
> it on day to day basis (spoken or written) my sentences might look/feel odd
> or as you put it "in your face".
> After ~4 months without solution, one can get a bit disappointed, and
> therefore a bit aggravated. Or it is just me ...
Perhaps you didn't reveal enough of your problem, or your problem isn't a 
samba problem ...

> > > 123 days with no solution, well my patience is getting thin...
> >
> > I've seen at least 2 or 3 responses with suggestions to your LAST rant,
> > but no response from YOU.
> >
> > > Please help me get this working in new samba....
> Lack of response from me is easy to explain. Nothing worked. I would be
> more than happy to report back that suggested solution worked, how it
> worked, have I made any changes, and of course I would paste that config
> here so anyone else can use it if found in similar situation.

It would really be nice to know - for us it looks like you never even bothered 
to  try, instead just continued to whine.


> Only once I was close to my goal, files were showing as owned as user:group
> of local user via smb but not if accessed directly through file manager,

You can't expect that. For your local linux file manager, the unix/linux 
settings (users umask, sgid flags, permissions, acls ...) apply - samba can 
only modify permissions on files it created or accessed.
In fact, your problem isn't a samba problem.

Some settings defaults may have changed between the versions, but that doesn't 
affect your "file manager".
Since you never posted the permission set of your share main directories, we 
simply had no clues due to no specific errors, no logs posted.

More information about the samba mailing list