[Samba] error 1310 when installing to a Samba share

Gary Dale garydale at rogers.com
Tue Apr 21 02:40:41 GMT 2009

I'm trying to install some income tax software to a Samba (Debian 3.2.5 
i386) share and I'm getting the above error. I've tried resolving it 
through the Windows knowledge base, which suggested it was the Windows 
Installer running as a local system account but even granting guest 
access to the directory and granting everyone rwx rights didn't help.

They also suggested un-registering then re-registering the installer. 
Again no luck.

I notice that the installer does create a zero-length with the correct 
ownership (<installer>:users) and full rwx rights to everyone, but it 
still complains. Confusingly, this is only one of multiple files that it 
installs. There are a reasonable number of other files that it puts in 
place correctly.

This is happening when I run the installer from both XP/Pro machines 
I've tried it on.

I can't find anything in the logs with syslog = 10. log.nmbd has no 
entries since Feb. 22, log.smbd just shows normal connections. 
log.<computername> again shows nothing that looks unusual.

Any ideas?

More information about the samba mailing list