[Samba] set up for Active Directory

McGranahan, Jamen jamen.mcgranahan at Vanderbilt.Edu
Tue Apr 14 14:33:02 GMT 2009

Running Sun OS 5.10 sparc.


OK, I am trying to establish an Active Directory connection from my Sun
Solaris box and am trying to utilize Samba to accomplish this task. I've
installed OpenLDAP & Samba, but when I run a few checks, it appears that
Samba is not seeing KRB or ADS, but is seeing LDAP & WINBIND. 


(This is Samba 3.3.3)

# cd /usr/local/samba/sbin

# smbd -b|grep LDAP








# smbd -b|grep KRB

# smbd -b|grep ADS

# smbd -b|grep WINBIND




I thought it might have been something with my ./configure script I ran
for samba, so I tried it again, but this time it tells me ldap is not


configure:59398: checking whether LDAP support is used

configure:59400: result: yes

configure:59423: checking for Active Directory and krb5 support

configure:59437: result: yes

configure:59580: checking for ldap_initialize

configure:59663: result: no

configure:59676: error: Active Directory support requires


UGH! So frustrating. I've been at this one project for a week now and
still have not been able to get this to work. Please - any guidance you
can provide would be a great help! Thank you!



* Jamen McGranahan 

* Systems Services Librarian 

* Library Information Technology Services

* Vanderbilt University

* Suite 700

* 110 21st Avenue South

* Nashville, TN  37240

* (615) 343-1614

* (615) 343-8834 (fax)

* jamen.mcgranahan at vanderbilt.edu



More information about the samba mailing list