[Samba] Samba 4 Alpha 7 Authentication issue

Andrew Bartlett abartlet at samba.org
Mon Apr 6 04:44:55 GMT 2009

On Mon, 2009-03-09 at 20:16 +0000, Matthew Holder wrote:
> Dear All,
> I am attempting to setup a DC using Samba 4 Alpha 7 as a learning
> tool. Eventually where I work will want a DC setup, and I can learn
> the skills needed using the alpha code.
> I have tried following the howto guide included with the source on the
> following setups:
> 3xvirtual machines using VMware.
> 1xphysical hardware using Ubuntu 8.10
> Each setup has stumbled at the same step:
> After compiling and installing alpha 7, I provision the system and
> then proceed to loading samba4, and testing, by using smbclient to
> view the [test] share I created as instructed.
> The problem I find is that whenever I enter
> ./smbclient //localhost/test -Uadministrator%PASSWORD
> the command never stops running. If I enter the incorrect password on
> purpose, then an error is shown (NT_STATUS_LOGON_FAILURE). Using a
> different username shows the following error
> I have tried using a simple password, a long password containing
> uppercase, lowercase, numbers and also a password with other
> characters in.

Is this spinning on the client or the server?  Is there network traffic
at the time?  Can you debug the client or server (whichever appears to
be doing the work) and get a backtrace?


Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org
Samba Developer, Red Hat Inc.                  http://redhat.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20090406/2fcd80bf/attachment.bin

More information about the samba mailing list