[Samba] Strange problems with Samba 3.0.32 as ADS member of W2k3 domain

Masopust, Christian christian.masopust at siemens.com
Thu Oct 30 13:59:05 GMT 2008

> > 
> > i've some strange problems with my samba-servers acting as 
> domain-member
> > (ADS) in a W2k3 active directory.
> > 
> > we have 3 DCs here and running samba without specifying a 
> dedicated "password server"
> > doesn't work!  the 3 DCs have the following roles:
> > 
> > - DC1: PDC-emulator, has global catalog
> > - DC2: RID-master, infrastructure-master, no global catalog
> > - DC3: no special role, has global catalog
> Have DC1 and DC2 been upgraded to Windows Server 2008 by any chance? I
> had similar problems. Machines that had already been joined 
> worked fine
> but new machines had to be joined to the domain by specifying 
> a DC that
> was still running W2k3.
> Upgrading to Samba 3.2 fixed those problems.
> Regards,

I now tried to run this configuration with Samba 3.2.3, but get the same
results. Access to shares is only possible when either "password server = DC3"
or "password server = *" AND winbind is running.

no one here who could help?    

what could i do to give more information? (I've a level-10 log, but this is
appr. 2MB...)

thanks a lot,

More information about the samba mailing list