[Samba] ntlm_auth fails to find PDC on same computer

Loren M. Lang lorenl at alzatex.com
Wed Oct 29 18:09:37 GMT 2008

I am trying to get ntlm_auth working for Authentication against the
local Samba PDC which is running on the same computer.  I am using samba
3.0.28a on Ubuntu 8.04.1.  smbd, nmbd, and winbindd are running and
Windows clients have no trouble logging into the domain.  Running
ntlm_auth --username=myusername reports No logon servers.  I ran the
command as root and according to strace, it looks like it connected to
the socket for winbind and the error was returned through that
connection.  I also tried specifying a domain with the same error. The
only thing in the log files for winbindd is "Could not receive
trustdoms"  I am suspicious that AppArmor might be misconfigured, but I
can't find any audit events related to samba.
Loren M. Lang
lorenl at alzatex.com

Public Key: ftp://ftp.tallye.com/pub/lorenl_pubkey.asc
Fingerprint: 10A0 7AE2 DAF5 4780 888A  3FA4 DCEE BB39 7654 DE5B
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20081029/475a34a7/attachment.bin

More information about the samba mailing list