[Samba] Samba findsmb and smbtree inconsistent

nabbleusr1234565 rogersusr123 at rogers.com
Sun Oct 26 17:42:12 GMT 2008

I have a samba server 3.0.28a set up on ubuntu 8.04, which is accessed by a
windows xp client. 
The windows machine can see and download all the shared folders from the
linux machine, and the linux machine can download from the windows machine
with smbclient. 
However, when I issue "findsmb" the linux machine only reports itself, not
the windows machine.  The man pages show it printing a list of machines for
the entire network.  Why is findsmb not listing the windows machine? 
Even though file and printer sharing is enabled in windows firewall findsmb
still doesn't list the windows machine.  I also tried disabling windows
firewall, still nothing.  I allow all traffic to my linux machine from lan
interface (currently).  This problem is somewhat similar to
Secondly, smbtree doesn't always return consistent results.  When I restart
my windows machine and do a smbtree from the linux machine, all of the
shared folders for linux and windows are listed.  Then a few minutes later
smbtree may only lists linux shared folders.  It seems inconsistent, is this
smbstatus seems to work.  When I'm connected to a linux shared folder
smbstatus lists the connection. 
Also, I added samba as a netbios server to dhcpd.conf, and configured it as
a domain master.
View this message in context: http://www.nabble.com/Samba-findsmb-and-smbtree-inconsistent-tp20176018p20176018.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list