[Samba] Re: cli_nt_create failed on pipe \spoolss. NT_STATUS_ACCESS_DENIED

Salah Coronya salah.coronya at gmail.com
Fri Oct 17 22:40:40 GMT 2008

Jeremy Allison wrote:
> On Wed, Oct 15, 2008 at 01:32:38PM -0500, Salah Coronya wrote:
>>> You might want to look into debugging the cups
>>> backend hp job (it's probably a script - try
>>> adding debug messages into it to find out what
>>> is going on there. Is it printing to a USB
>>> printer ?
>>> Jeremy.
>> It is a USB printer. The printer works just fine locally, its only when  
>> going though Samba it doesn't work. It worked before the upgrade to  
>> Fedora 9.
> You're just going to have to track this through
> the cups system. All Samba is doing is calling
> cups_job_submit() to push the job into cups via
> IPP.
> Jeremy.

I finally solved the problem. The solution was to comment out the line 
in smb.conf that said "cups options = raw". Now it works just fine (my 
Gentoo box did not have this particular line which is why I had no 
problem there)

More information about the samba mailing list