[Samba] opensuse 11 samba 3.2.4 ldap add machine solved

Robert Schetterer robert at schetterer.org
Wed Oct 8 09:55:00 GMT 2008

Robert Schetterer schrieb:
> Hi @ll,
> i didnt worked on samba for a while now had setup a new domain contoller
> on opensuse 11
> i used the repositories from download.opensuse.org samba 3.2.4
> i mostly copied stuff from working suse 10 samba ldap pdc
> and configured /etc/nsswitch.conf smb.conf
> in equal ways , testparm shows no bugs
> as well as getent passwd etc does not,
> populating ldap worked fine
> fixing dbus boot stuff in /etc/ldap.conf by boot_policy soft etc
> but i didnt got managed joinig the domain by the root user
> with a new installed winxp serv pack3 german client
> bug message means "no such user"
> it looks like it haves problems finding the root user
> adding another user and putting him in the domain admin with the latest
> smbldaptools script group doesnt helped either.
> samba client logs doesnt report root not to be not found
> I just googeld around and found likly problems with opensuse 11
> mostly telling to upgrade openldap and samba, but now i am on the latest
> upgrade level, so before i just loosing more time , just wanna ask if there
> are known problems with samba ldap on opensuse 11?
> And if ther are known one ,how were  they fixed
solved in /etc/ldap.conf

nss_base_user   ou=Users,dc=...,dc=...

changed to

nss_base_user   ou=Computers,ou=Users,dc=...,dc=....

Best Regards

MfG Robert Schetterer


More information about the samba mailing list