[Samba] Existing files don't show up in share, new files do

Pepijn Schmitz samba at chaos.demon.nl
Wed May 21 11:37:48 GMT 2008


Does this ring a bell with anyone? I'm still at a loss and so it seems 
is everyone else... :-)

In short: on one of my existing Samba 3.0 shares (Linux server, ext3 
filesystem) all existing files have suddenly become invisible, but it is 
still possible to create, modify and delete new files (and I see no 
differences between these new files and the existing ones). This happens 
with Windows XP, Windows Vista, Linux CIFS and Linux smclient clients, 
so it is likely to be a server problem. I'm stuck and I'm hoping a 
bright mind from this list will be able to help!

Kind regards,
Pepijn Schmitz

Pepijn Schmitz wrote:
> I found out this bizarre problem also occurs when I mount the share 
> from another Linux system, so it does not appear to be related to 
> Windows.
> To recap: one of my Samba shares suddenly mysteriously hides all 
> existing files, while still working completely normally with any newly 
> created files.
> The shared directory (/mnt/data/multimedia) looks like this:
> drwxrwxrwx 11 pepijn pepijn   4096 2008-05-17 14:08 .
> drwxr-xr-x 10 root   root     4096 2008-05-16 19:58 ..
> drwxr-xr-x  6 pepijn pepijn   4096 2006-07-02 15:49 Audio
> lrwxrwxrwx  1 pepijn pepijn      6 2005-01-17 22:13 Fotos -> Foto's
> drwxrwxr-x 41 pepijn pepijn   4096 2008-03-15 23:27 Foto's
> drwxrwxr-x  4 pepijn pepijn   4096 2002-07-01 02:32 Martijn
> drwxrwxr-x  2 pepijn pepijn   4096 2002-03-31 04:48 recycled
> drwxrwxr-x  2 pepijn pepijn   4096 2004-11-28 17:00 temp
> -rwxr--r--  1 pepijn pepijn      6 2008-05-17 14:08 test.txt
> drwx------  4 pepijn pepijn   4096 2005-07-02 16:17 .Trash-500
> drwx------  2 pepijn pepijn   4096 2005-04-02 13:54 .Trash-pepijn
> drwxrwxr-x 10 pepijn pepijn   4096 2008-03-15 23:31 Video
> -r-xr--r--  1 pepijn pepijn     80 2005-07-10 19:07 volumeid.zbx
> drwxr-xr-x  4 pepijn pepijn   4096 2007-12-07 22:15 XXX
> When I mount the share on another Linux system using mount -t cifs, 
> the contents look like this:
> drwxrwxrwx 11  500  500    0 2008-05-17 14:08 .
> drwxr-xr-x  4 root root 4096 2008-05-17 14:06 ..
> -rwxr--r--  1  500  500    6 2008-05-17 14:08 test.txt
> The test.txt is a file I created since this problem started and as you 
> can see it's the only one visible. I can change its contents on the 
> file server and see the changes on the client. I can manipulate the 
> file on the client, even create new files, it all works perfectly. But 
> I can't see any of the existing files or directories. It's utterly 
> bizarre to me.
> I tried using smbclient, and it displays the same behaviour, so it 
> really looks like the problem is on the server side. I tried 
> "touch"ing the existing directories but that made no difference either.
> Does anyone know what might cause this strange behaviour?
> Kind regards,
> Pepijn Schmitz
> Pepijn Schmitz wrote:
>> I am suddenly no longer able to see any existing files on one of my
>> shares, from my Windows clients.
>> I have a Linux server (Fedora Core 8) which used to be my firewall and
>> router as well as file and print server. There are two Samba shares on
>> it I have mounted on various Windows clients: my home directory and a
>> multimedia directory with my music and videos, etc. I mount the former
>> as H: on all my Windows machines and the latter as M:.
>> Recently I installed a new server to be router and firewall. I kept the
>> existing server as file server though, only it now no longer has a fixed
>> IP address, and it is no longer configured to be be the master browser.
>> Since this change, my Windows clients no longer see the existing files
>> on the multimedia share! Some strange features of the problem are:
>> * It occurs on my Windows Vista Home Premium 64-bit machine, as well as
>> on my Windows XP SP2 machine, in exactly the same way.
>> * My home directory share doesn't have the problem, I can still see all
>> the existing files there.
>> * There are no errors connecting to the share from the Windows side, nor
>> do I see strange things in the logs on the file server.
>> * I can still create new files on the share from Windows! The new file
>> will show up locally on the file server (as verified by logging in with
>> SSH and checking the shared directory), and my other Windows client will
>> see the new file as well.
>> * I can also create new files locally on the file server, and these will
>> also show up on the Windows clients.
>> * I can see no difference between the existing files and any new files
>> created locally or through a Windows client. The file permissions are
>> all the same.
>> * The only difference between the two shares is that my home directory
>> is on the root filesystem (ext3) and the multimedia share
>> (/mnt/data/multimedia) is on a mounted ext3 file system (/mnt/data). But
>> this hasn't changed!
>> * While googling the problem I found some references to a "directory
>> name cache size" option which might be related, so I added a "directory
>> name cache size = 0" to my smb.conf, but that made no difference.
>> I've attached my smb.conf (I've removed all the comments for brevity).
>> I'll provide any log, trace or debug info if someone tells me how to.
>> Hopefully somebody here can help me!
>> Kind regards,
>> Pepijn Schmitz

More information about the samba mailing list