[Samba] got stuck in setting up samba to linux box through putty tunneling

Dan Guo duanyang at yahoo.com
Wed May 7 17:46:00 GMT 2008

I read the posting below. but I have not figured out why my vista pc won't work.
here is what I did - 
1. I disable window file sharing;
2. in putty, i add a tunnel: 
     source port: 445
     destination port: my linux box IP: 139
   I forward 80. i see yields my web server's start page.
3 i also use secpol.msc and change local policies -> security options.
By default Windows Vista sets the policy to "NTVLM2 responses only". Change this to "LM and NTLM – use NTLMV2 session security if negotiated".

4. i start a putty session and login in.
5. i try to use this command: 
      net use Z:  \\\myid /user:myid
    i was prompted to input the password. I input the right passwords. it failed. i got again asked about passwd. I input again and fail again. this time, it shows an error msg: 
    System error 86 has occurred.
    The specificed network password is not correct. 
6. for my vista pc, i use a cisco 800 router from my cable company. 
Can anyone help find out what is wrong? 
thank you,
>Well, it looks like I needed to forward port 445. I have it working now. 

Charles Bueche wrote:
>I would check to forward port 445. XP tries this one before 139 and 
>Are you sure that your remote Samba listen on ?
>Show us your smb.conf
>On 5 mars 07, at 07:47, Richard D. Morey wrote:
>>After having scoured the net for a way to do SMB over SSH with Windows,
>>I've tried everything I have found and I still can't get it to work.
>>I'm using Windows Vista as the client and FC6 with Samba 3.0.24-1 as the
>>server. I have set up a share and can successfully connect to that share
>>with no ssh tunnel.
>>I would like to tunnel SMB over SSH, so here is what I have tried:
>>1. Disabling Windows File Sharing with "net stop server". Then, using
>>puTTY, I connect with my ports forwarded. I forward 80 and 139.
>>"" yields my web server's start page, so I know
>>forwarding is working. When I "telnet 139" it connects to the
>>SMB server successfully. "netstat -ano" reveals that and
>> are listening with puTTY.
>>However, trying to map a network drive fails. \\\share yields
>>the error "The specified network name is no longer available." or 
>>"Network path not found." I know the share is working because I can 
>>access it without SSH at the same time.
>>Here are two lines from netstat when I have the telnet session open:
>>tcp        0      0        
>>tcp        0      0          
>>2. I have tried adding the loopback device as detailed all over the web
>>(ie http://www.blisstonia.com/eolson/notes/smboverssh.php ,
>>When I do this, I can access the webserver via the loopback device but
>>"telnet 139" times out. However, puTTY appears to be listening
>>on and I cannot add the share either. I have 
>>done everything I can think of to get this to work.
>>In addition, I have disabled Windows listening on port 445 (as 
>>suggested in one of the guides) I have tried giving puTTY the actually 
>>IP of the samba server as the destination, I have ensured that 127. is 
>>allowed by the smb.conf...
>>What could be going wrong here? Any ideas?
>>--Richard D. Morey, M.A.
>>Research Assistant, Perception and Cognition Lab
>>University of Missouri-Columbia
>>--To unsubscribe from this list go to the following URL and read the
>>instructions:  https://lists.samba.org/mailman/listinfo/samba
>--Charles Bueche <charles at bueche.ch>
>sand, snow, wave, wind and net -surfer
>A-Cat SUI 192

More information about the samba mailing list