[Samba] Still no joy using "print command" with 3.0.30

Stuart Reedy stu at coe.uky.edu
Wed Jun 25 20:57:13 GMT 2008

Greetings once again,

I am still having trouble with the "print command" option in 3.0.30.

In our computer lab, we force CUPS to print the jobs on hold, using:

print command = lp -H hold -d %p %s

This worked well with the Slackware packages of Samba 3.0.28 and CUPS 
1.1.23.  When I upgraded Samba to 3.0.30, the jobs were no longer queued 
on hold, but printed immediately.

To troubleshoot the problem, I wrote a script that copies the command 
line to a file, then replaced "lp" with this script.

With 3.0.28 the script writes its output to the file and the job never 
prints.  With 3.0.30 there is no output from the script and CUPS prints 
the job.

In an effort be a good citizen, I removed the Slackware distribution of 
Samba, then compiled it from source, using:

./configure --enable-cups --enable-static=no --enable-shared=yes 
--with-fhs --with-acl-support=yes --with-automount --prefix=/usr 
--localstatedir=/var --bindir=/usr/bin --sbindir=/usr/sbin 
--with-lockdir=/var/cache/samba --sysconfdir=/etc 
--with-configdir=/etc/samba --with-privatedir=/etc/samba/private 
--with-swatdir=/usr/share/swat --with-smbmount --with-quotas 
--with-syslog --with-utmp --with-libsmbclient --with-winbind

Still no joy.  CUPS immediately prints jobs and the specified "print 
command" seems to be ignored.

I would greatly appreciate any help that folks may wish to offer.

Here are the details, in case they are important:

Slackware 11.0 using Linux kernel
CUPS is the Slackware package of 1.1.23.

/etc/samba/smb.conf looks like:

         workgroup = ITC
         server string = Samba Server
         passwd program = /usr/bin/passwd %u
         unix password sync = Yes
         ldap ssl = no
         hosts allow = 172.20.,
         ea support = Yes

         comment = All Printers
         path = /var/spool/samba
         printable = Yes
         browseable = No

         path = /var/spool/samba
         read only = No
         printable = Yes
         print command = lp -H hold -d %p %s
         printer name = test
         oplocks = No
         share modes = No

Stuart Reedy               Working hard for a great university!
stu at coe.uky.edu
859 257-7966               http://www.coe.uky.edu/~stu/

More information about the samba mailing list